Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I installed Ubuntu 12.04 alongside Windows 7 on a separate partition, with mount point '/' and boot load information on Windows 7 drive (settings, prior to installing Ubuntu). When I start the system, Grub boot loader shows both options for selection but when Windows 7 is selected, screen just goes blank for less than a second and Grub menu reappears. I checked in file explorer in Ubuntu and the drive of Windows 7 is still as it should be.

How do I get Windows 7 back running, I need it badly...?

And I could not get any proper answer for it, I have already Googled it, so please do not advice that. Please give me some proper explanation for solution or if you find any link properly explaining the solution, you can paste it here.

share|improve this question
    
when you installed ubuntu : have you removed any partition ? –  Antoine Rodriguez May 13 '12 at 12:57
    
No, everything is as it was before installing Ubuntu. I just selected a partition that was free enough (it contained data already). Only difference would be that the filesystem must have changed to Ext4 from Ntfs on which Ubuntu is installed. –  TheSuyog May 13 '12 at 13:14
    
you installed ubuntu on the same partition as windows ? –  Antoine Rodriguez May 13 '12 at 13:20
    
Nope, I installed it on a different partition. Are you trolling me? 'coz that was the first thing I mentioned... –  TheSuyog May 13 '12 at 13:25
    
I'm not trolling you, I just try to have some more details of your trouble in order to give you a better answer ...... The fact that grub re appears show that you have somehow damaged the boot loader of windows 7 .... that's why I ask you those questions. More details are welcome in order to have a better understanding. –  Antoine Rodriguez May 13 '12 at 13:35
show 2 more comments

6 Answers 6

You're problem, if it is like mine, requires a more simple solution. If you get the grub loader menu and it shows Windows 7 but when you select that it does not boot, select the line for the system you want to boot and press 'e' on the grub menu. This will bring you to an entry something like as follows:

insmod part_msdos 
insmod ntfs 
Set root = '(hdx, msdosx)'

You usually don't need to worry about the other lines that follow so I've not included them here. Edit the x value so that sdb is hd1 or sda is hd0, for example-get those numbers to match yours. Edit the msdosx value to match yours as well, but the partition number, unlike the disk number starts with 1; not 0.

share|improve this answer
add comment

Since you have not deleted any partition (so the recovery partition of windows 7 is still there) you can proceed like this :

In order to have windows 7 back just run the windows 7 CD in repair mode.

follow this in order to have the console : http://pcsupport.about.com/od/toolsofthetrade/ss/windows-7-startup-repair.htm

Under the console you'll type :

fixboot

and

fixmbr

Those two commands will restore normaly the whole windows 7 boot process. if not follow the procedure of the link I gave you.

So now you are in single boot with windows 7 and Ubuntu is "disabled"

In order to restore Ubuntu and activate the dual boot correctly you may want ubuntu back.

For that follow this link at the easybcd part : http://www.linuxbsdos.com/2011/05/22/how-to-dual-boot-windows-7-and-ubuntu-11-04/2/

I hope It'll fix you everything. Because it's a repair of the boot process be informed that you can loose the boot of both systems. However you don't loose any data. The best thing is to have another computer next to you or print the links in case of more complex situation. Also have an ubuntu cd that will help you to access to internet in case of that kind of situation.

Best regards,

share|improve this answer
    
My problem seems too big... I tried that solution but the Startup Repair itself does not start. I booted from the Windows 7 DVD, it loaded he system files but then generated a Fatal Error message telling something like this "Could not load /Windows/System32/Boot/winload.exe File is either deleted or corupt" –  TheSuyog May 13 '12 at 15:54
    
Moreover, sites do not load in any browser in Ubuntu, they just keep on loading forever, even like facebook. This never used to be a problem in Windows. First link did not open either but I knew what do to, but I am a total noob in Linux environment. Hope you can help... –  TheSuyog May 13 '12 at 15:57
    
What you said in your first message may be due to an hardware failure (such as memory defect or bad cluster) or that ubuntu at the installation process has corrupted your windows partition. Either ways it would be wyse to save your data (windows ones and Linux ones) on a external storage (such as usb drive). Afterwards you have to check before attempting anything your hardware. there is a cd called UBCD that will help you. Do a memtest (will last 40 minutes) and a long hard drive test with the correct hard drive diagnostic tool on the cd (depending on brand). Tell me when you have done those. –  Antoine Rodriguez May 13 '12 at 16:10
add comment

I just had the same problem and I solved it.

I fixed my Windows 7's boot loader as Antoine recommends.

Then there was only Windows 7 and no sign of Ubuntu.

I installed EasyBCD -it's free for personal use and can be downloaded from this address.

Then I ran the app and I added the Ubuntu boot menu alongside the Windows 7.

With this app it's easy. Now it's working properly. If you chose the Grub 2 boot loader, it will be easier to configure the loader.

Thanks.

share|improve this answer
add comment

Are you using AHCI/UEFI in your BIOS (instead of MBR partitioning)?

I have the same problem and the options are either to reformat and use Windows with MBR and then Ubuntu and Windows will boot properly or keep AHCI/UEFI and you have to disconnect physically the drive containing the Ubuntu OS.

share|improve this answer
add comment

The problem is not with Windows 7 loading and Ubuntu not loading. It was the other way round.

Easy BCD, afaik, works in the Windows environment. The problem is that after loading Ubuntu 12.04 on a separate partition(in my case with Vista earlier functioning), my Vista does not boot up any longer.

Thankfully the files are available through the Ubuntu.

share|improve this answer
add comment

You might have to reinstall both. I had to it takes about 5 hours, good directions online. Do your research. I was sucessful. Take your time. Good luck. There's a good article online, toward this issue

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.