Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

The jack-audio-connection-kit needs to run in realtime mode and my system is configured accordingly. I'm using the fglxr driver.

With Unity-2d everything is fine.

With Unity-3d, jack-clients disconnect from jack very often, usually when something happens to windows (being drawn first time, brought to front, opening menus ...).

It's still the same driver, but it seems like the 3d accleration part of it is not preemptable.

What are my options besides sticking to Unity-2d (I really painfully miss window drop- shadows)?

I did not even find a way to report a bug against the driver itself, and do not know how to further diagnose the issue, anyway.

share|improve this question

3 Answers 3

up vote 1 down vote accepted

Switch to the radeon driver!

Today I found out, that Unity 3D works with radeon (after removing leftovers of other drivers!).

The disconnects (or xruns with larger timeout) are gone.

share|improve this answer

You may try this: Install QjackCtl and click Setup. From there, you increase timeout to 500 msec under Parameters.

share|improve this answer
    
Or use the -t option to jackd. The result is no disconnects, but lots of xruns. Not a solution, in the end. –  thorwil May 15 '12 at 7:20

Use qjackctl, I launch jackd priority 70. Check /etc/default/rtirq, if you dont have this file you need rtirq package to set rt priority and also need to be member of 'audio' group. Disable pulseaudio to minimize resource consumption during jack rt audio usage. Upgrade to low-latency kernel. Install schedtool, launch jackd and clients and use system monitor to find resource hogs and pid of your audio processes. In x-term use schedtool to adjust interrupt scheduling of audio processes. Linux Audio Users website is good starting point for info. I personally use Jackd ardour and hydrogen to record multi-track drums with no over-runs and system resources to spare. Tuning a system for rt audio can be tricky with many variables requiring different tweaks depending on hardware and system resources.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.