Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I'm using Ubuntu 12.04 on my Lenovo G550. I noticed that Ubuntu disabled the startup sound played after login (I love it). I did some Googling and found on UbuntuGeek that we have to add this command

 /usr/bin/canberra-gtk-play --id=”desktop-login” --description=”GNOME Login sound” 

to Startup Applications. I did that but I still don't hear the sound.

share|improve this question
1  
Did any of the answers help you? If that's the case you could accept that answer so this question is marked as solved –  rearlight May 16 '12 at 20:56

3 Answers 3

up vote 1 down vote accepted

For some odd reasons command available on Ubuntu Geek is not working, But the following command is working for me.

/usr/bin/canberra-gtk-play --id="desktop-login" --description="GNOME Login"

How to setup?

  • Click on Gear icon (Session indicator) in Unity panel, And open "Startup Applications".

enter image description here

  • Click add and fill out as follows
Name: GNOME Login Sound
Command: /usr/bin/canberra-gtk-play --id="desktop-login" --description="GNOME Login"
Comment: Plays a sound whenever you log in

enter image description here

  • Click save and logout. That's it!
share|improve this answer
    
I think the question poster means the old login/start up sound. Your answer only indicates how to enable/disable the new login sound in 12.04. –  rearlight May 13 '12 at 10:02
    
The funny thing is that is "ON" but I still don't get the sound –  pratnala May 13 '12 at 11:08
    
Yes @rearlight, that's what I mean - the "old login/start up sound" –  pratnala May 13 '12 at 11:09
    
Solved. Thanks. –  pratnala Jun 14 '12 at 9:09

I've had a similar problem and after hours of searching I've found a solution to the following problem:

  1. I could not select any alert sounds - they were greyed out.
  2. using canberra-gtk-play --id="desktop-login" resulted in: Playing sound failed: Sound disabled

Solution:

With dconf-editor (package dconf-tools) select org.gnome.desktop.sound. Select the event-sounds so it is marked: Do not use the default button! Yes that's weird! Even though the default button sets the check box to true -it will not work. The check box has to be selected manually (well by mouse :-)

After that I had all alert sounds I needed.

share|improve this answer

I've run the command /usr/bin/canberra-gtk-play --id="desktop-login" --description="GNOME Login" in a terminal and it did something, but I did not hear any sound.

There are 2 possible workarounds:

  1. Experimenting with the --volume option (did not work for me)

    You can change the command to /usr/bin/canberra-gtk-play --id="desktop-login" --description="GNOME Login sound" --volume=10 and see if you can hear anything then. Higher values are possible.

  2. Changing the login sound command entirely (worked for me)

    You can create a startup application as indicated by Basharat and as command use this: paplay /usr/share/sounds/ubuntu/stereo/desktop-login.ogg

    For Name and Comment, you can fill in what you want.

I hope that could help.

EDIT: I've used the wrong quotes first, but I still hear nothing when I use /usr/bin/canberra-gtk-play --id="desktop-login" --description="GNOME Login" in a terminal. So the command definetly doesn't work for me.

share|improve this answer
    
2. Is the boy for me! –  fleamour May 15 '12 at 21:03
    
The problem is the quotes were different. that's why the sound didn't come –  pratnala Oct 28 '12 at 8:32
    
@PratyushNalam Man, damn german keyboard layout.. I will edit my answer. Thanks for your hint! –  rearlight Oct 28 '12 at 11:50
    
reboot. after reboot, it worked for me –  pratnala Oct 28 '12 at 11:56

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.