Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I'm trying to watch my sky films but I need silverlight of course. I have tried downloading moonlight 4 on Chromium - says: cannot unzip package so does not finish download In the latest Firefox of course it's not compatible (yet?)


I'm new to Ubuntu,I can follow instructions

Is there anyway I can get around this?

share|improve this question
add comment

2 Answers

Moonlight 4.0 is compatible with Firefox 12.0 (Latest stable release for Ubuntu). To install follow these steps:

  • Open Firefox and visit Moonlight download page
  • Select your the architecture of you system (32bit or 64bit)
  • Click on download button, Firefox will show you a confirmation box click allow.

enter image description here

enter image description here

  • Click on "Install Now" on the installation dialog box.

enter image description here

  • Upon completion of download click on restart. That's it!

enter image description here

After restart you'll see Silverlight plug-in listed under installed plug-ins.

enter image description here

share|improve this answer
add comment

Move the .mozilla folder from- /home/your user name/.mozilla to a different name like mozilla_old.

Then try installing the moonlight again.

Caution : deleting .mozilla will remove everthing. I mean your addons and bookmarks.

share|improve this answer
    
Since there has been a bit of fulrry in chat about the danger of this answer, I've revised it a bit. With that said, how would this help? –  hexafraction Dec 3 '12 at 20:36
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.