Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

This problem seems to be opposite of any other wine sound problems, sound works beautifully in World of Warcraft under wine, but it remove all audio output for other programs such as Mangler and the system sound test program. I have tried starting programs before and after WoW to see if that will make the audio work but that doesn't help, I'm all out of ideas.

share|improve this question
    
Can you add what WINE version you are using and Ubuntu version you are using. –  Luis Alvarado May 13 '12 at 1:10
add comment

2 Answers 2

I was trying to figure out what was causing this issue for me and the post above about "Disable background info" had me thinking about in-game sounds. The setting was actually called "Enable sounds in background" for me (version 4.3.4 at the time), though that didn't fix it. I copied this installation from my Windows install and so all the settings were the same. I noticed I had my sound channels set to "High (64)" and when I swapped to "Low (24)" immediately the sound buffered in Mangler all played at once. I still left "Use Hardware" checked, and haven't had issues so far but I haven't done extensive testing. Hope this helps!

share|improve this answer
add comment

I played World of Warcraft about a year ago and this is actually a setting. In your audio menu there should be a checkbox that says something along the lines of "Disable background audio". Just uncheck that.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.