Ask Ubuntu is a question and answer site for Ubuntu users and developers. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I still can't seem to play movie DVDs on my Ubuntu 11.10 even after installing restricted extras and after trying this

This[a] is the error message that I get with movie player. VLC doesn't play the DVD either.

What gives

[a]Could not read DVD. This may be because the DVD is encrypted and a DVD decryption library is not installed.

share|improve this question
up vote 8 down vote accepted

Open the Terminal under Applications > Accessories > Terminal and run the following commands:

sudo apt-get install libdvdnav4 libdvdread4 gstreamer0.10-plugins-bad gstreamer0.10-plugins-ugly

sudo /usr/share/doc/libdvdread4/


share|improve this answer
Strangely it worked this time around. I guess I might have been somehow missing something previously. Thanks. – drN May 13 '12 at 5:02
This worked for me as well. The first command did nothing (I already had all the packages) but the second command got things going. Was on Xubuntu 13.04 with Extra Restricted installed. – Treepata Mar 28 '14 at 18:43

This link is a well written response the these kind of problems, including troubleshooting. Well worth a read Let us know if it helps Good Luck - Mal

share|improve this answer

From: http://

Originally Posted by uRock View Post https:// You need to install packages for decrypting the movies.


wget -c
sudo dpkg -i libdvdcss2_1.2.9-2medibuntu4_i386.deb


wget -c
sudo dpkg -i libdvdcss2_1.2.9-2medibuntu4_amd64.deb


share|improve this answer

QUICKTIME. I stumbled to this post after searching the net for weeks. I tried everything, including "regionset". Today, after 4 weeks, I find my own solution, AFTER playing the dvds in Mac and Win7 and then browsing Filehippo for clues. QUICKTIME ! We need to install the quicktime lib and util, in addition to all the restricteds, libs, etc advised in the Ubuntu forum. Use Synaptic for this. This solved the problem why commercial dvd in China would not play. ps... if you get an error message about "blocks", your drive may be faulty.

share|improve this answer

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.