Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

This question already has an answer here:

I have an older Sony VAIO Z 590 laptop with switchable graphics between Intel and Nvidia GeForce 9300M. It is NOT Optimus. I did a clean install of Ubuntu 12.04. Everything works, but it's using Unity 2D with the Intel drivers. I've tried loading the Nvidia drivers from "Additional Drivers", but it says "this driver is activated but not currently in use".

When I run "nvidia-settings", an error window pops up to say "You do not appear to be using the NVIDIA X drivers." "lspci" shows both graphics cards. Let me know if I should add more info.

How do I get the Nvidia graphics and Unity 3D working?

More info:

$ lshw -short -class display

H/W path       Device  Class       Description
============================================== 
/0/100/1/0             display     G98 [GeForce 9300M GS] 
/0/100/2             display     Mobile 4 Series Chipset Integrated Graphics C

$ glxinfo
name of display: :0
Xlib:  extension "GLX" missing on display ":0".
Xlib:  extension "GLX" missing on display ":0".
Xlib:  extension "GLX" missing on display ":0".
Xlib:  extension "GLX" missing on display ":0".
Xlib:  extension "GLX" missing on display ":0".
Error: couldn't find RGB GLX visual or fbconfig

Xlib:  extension "GLX" missing on display ":0".
Xlib:  extension "GLX" missing on display ":0".
Xlib:  extension "GLX" missing on display ":0".
Xlib:  extension "GLX" missing on display ":0".
Xlib:  extension "GLX" missing on display ":0".
Xlib:  extension "GLX" missing on display ":0".
Xlib:  extension "GLX" missing on display ":0".

Excerpts from Xorg.0.log:

[    16.373] (II) LoadModule: "glx"
[    16.373] (II) Loading /usr/lib/x86_64-linux-gnu/xorg/extra-modules/libglx.so
[    16.386] (II) Module glx: vendor="NVIDIA Corporation"
[    16.386]    compiled for 4.0.2, module version = 1.0.0
[    16.386]    Module class: X.Org Server Extension
[    16.386] (II) NVIDIA GLX Module  295.49  Tue May  1 00:09:10 PDT 2012

[    16.608] (II) NVIDIA dlloader X Driver  295.49  Mon Apr 30 23:48:24 PDT 2012
[    16.608] (II) NVIDIA Unified Driver for all Supported NVIDIA GPUs

[    17.693] (EE) Failed to initialize GLX extension (Compatible NVIDIA X driver not found)
share|improve this question

marked as duplicate by Luis Alvarado Jun 29 '13 at 4:48

This question has been asked before and already has an answer. If those answers do not fully address your question, please ask a new question.

    
Try to install the driver through a terminal with sudo apt-get install nvidia-current and reboot after that if it works without errors. –  jP_wanN May 13 '12 at 8:39
    
Tried that but it fails to load. In the X.org log it says it can't load GLX for Nvidia, then it unloads that driver and loads VESA for Intel. –  projectshave May 15 '12 at 3:18
    
Does it get installed correctly? –  jP_wanN May 15 '12 at 6:42
    
The nvidia drivers? Yes, I believe so. No errors, libglx is linked to the nvidia version, AFAIK. The docs say my GPU is covered. If I completely remove nvidia, it loads the Intel drivers and run Unity 3D. –  projectshave May 15 '12 at 12:10
    
You could try a newer version by executing sudo add-apt-repository ppa:ubuntu-x-swat/x-updates and then sudo apt-get update && sudo apt-get dist-upgrade –  jP_wanN May 16 '12 at 6:42
show 4 more comments

1 Answer 1

Download the latest drivers from nvidia.com and then use this tutorial to install them: http://forums.linuxmint.com/viewtopic.php?t=96260&f=42

share|improve this answer
    
Unfortunately, Nvidia says "Some designs incorporating supported GPUs may not be compatible with the NVIDIA Linux driver: in particular, notebook and all-in-one desktop designs with switchable (hybrid) or Optimus graphics will not work if means to disable the integrated graphics in hardware are not available." AFAIK, Sony doesn't have a way to switch off Intel in the BIOS. I'll check again, though. –  projectshave May 16 '12 at 13:28
    
you said your card is non optimus in question...which one is correct? –  Web-E Mar 24 '13 at 4:59
add comment

Not the answer you're looking for? Browse other questions tagged or ask your own question.