Ask Ubuntu is a question and answer site for Ubuntu users and developers. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I have a Ubuntu 12.04 image on a flash drive. When I boot from that, I'm able to resize the icons in my launcher, and windows snap to half the screen. I assume this means that I'm running ubuntu 3d.

I just upgraded from Ubuntu 11.04 up to 12.04 (not a fresh install). Running the Ubuntu 12.04 installed on my hard drive, I am not able to resize the icons in my launcher nor snap the windows to half the screen. This command seems to say I'm in Ubuntu 2d, even though I have tried logging out, and specifically logging in with the regular Ubuntu rather than Ubuntu-2d.


How do I get the Ubuntu installation I have on my hard drive to act like the one I ran from the flash drive?


Update: Here is the output of the debugging commands, as requested.

$ cat /var/log/Xorg.0.log

Output in:

$ lspci -nn | grep VGA
2.0 VGA compatible controller [0300]: Intel Corporation 2nd Generation Core Processor Family Integrated Graphics Controller [8086:0116] (rev 09)

$ /usr/lib/nux/unity_support_test -p
Xlib:  extension "GLX" missing on display ":0.0".
Error: GLX is not available on the system

If anyone needs anything else, let me know. I don't really know what is important for this issue.

share|improve this question
We need more hardware information to help you, can you look at this question and then edit your question adding the information. – fossfreedom May 12 '12 at 22:07
up vote 1 down vote accepted

Fixed it!

Following the instructions on this thread,, I removed the nvidia-current and nvidia-settings packages.

sudo apt-get purge nvidia-*

Now I'm able to log into an Ubuntu-3d session. Once in an Ubuntu-3d session, I'm able to resize the dock, and snap windows to the sides of the screen.

share|improve this answer

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.