Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I am using Ubuntu 10.04 and it was working fine until recently that I had problems with my graphic card which I fixed it and now I have problems with internet connection. I have no internet connection, no wireless no LAN. It is interesting for me since it was working two weeks ago and it suddenly stopped working. Also I don't have any problems in my windows. Can you please help me to find the problem? I can send you screen shots if you need me to run any commands...

Thanks,


here's the outputs for the following commands:

ifconfig; cat /etc/network/interfaces
ifconfig ethX up (tried both eth0, and eth1)

ifconfig
lo Link encap:Local Loopback
inet addr:127.0.0.1 Mask:255.0.0.0
inet6 addr: ::1/128 Scope:Host
UP LOOPBACK RUNNING MTU:16436 Metric:1
RX packets:744 errors:0 dropped:0 overruns:0 frame:0
TX packets:744 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:0
RX bytes:57160 (57.1 KB) TX bytes:57160 (57.1 KB)

cat /etc/network/interfaces
auto lo
iface lo inet loopback

ifconfig eth0 up
eth0: ERROR while getting interface flags: No such device

share|improve this question
    
what's the output of these commands: ifconfig cat /etc/network/interfaces –  jackweirdy May 12 '12 at 19:02
    
output: cat/etc/network: error fetching interface information: Device not found –  zghaf May 12 '12 at 20:44
    
he wants: ifconfig; cat /etc/network/interfaces –  warl0ck May 13 '12 at 3:17

1 Answer 1

type the command ifconfig and post the information out here, then try to up your ethX via command: ifconfig ethX up (X depends on your own network adapter number, eth0 for me).

ifconfig ethX down # this command can bring your ethX down 

I just propose this potential answer to make other specialist to focus on your question, hope it helps. :D

UPDATED ANSWER:

Possible reasons I can tell:
1) your ethX is down by default, so ifconfig can't print it out. Try ip link show to find out your X number, and bring it up.

2) make sue your network adapter is properly inserted on your mainboard. (you mentioned it's ok for windows, so it's not the point of this issue :D

3) ethX is a virtual device, refer to no /dev entry, so if the system can't detect your ethX, it means that your need to add network card support to the kernel if you recompiled it!!!(since you mentioned you fixed a issue of your graphic card, so I think you may recompile your kernel or replaced a new one which may not support network card?)

4). SORRY, i've no idea, need other specialists' support :D

share|improve this answer
    
eth0: ERROR while getting interface flags: No such device –  zghaf May 13 '12 at 18:53
    
thx for your information, and if the ethX is down, ifconfig can't print its information(I tested on my ubuntu10.04). Try this command ip link show, what's the result? If we're lucky enough that any ethX displayed, turn it up. CHECK MY UPDATED ANSWER. –  vicd May 14 '12 at 16:26

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.