Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free.

I am setting up a dual boot install for my wife's computer. I would like to disable the timeout for selecting OS that defaults to Ubuntu so the computer wont boot without making a selection. (IE. GRUB_TIMEOUT=INFINITE) Is it just a simple case of leaving it blank or #out the line in /etc/default/grub ? I want it so my wife can choose OS easily on her newly Dual booting PC.

I would also like to know if updating Burg after this would keep the change - as the big graphics of the OS's are a little more noob friendly.

share|improve this question

3 Answers 3

up vote 15 down vote accepted

Change GRUB_TIMEOUT value from 10 to -1, save the file and then run sudo update-grub2. Reboot and now you have infinite time to choose the OS.

While this works in GRUB, it doesn't work with BURG, and you'll have to change GRUB_TIMEOUT value to some large number like 120 seconds to wait before booting into any OS and run sudo update-burg to reflect the changes. Also note that this change must be made to file /etc/default/burg as BURG doesn't consider options set in /etc/default/grub

share|improve this answer
    
Excellent answer. Thank you very much. I set it to 600 seconds with Burg and it's awesome. –  Lasher May 12 '12 at 19:50

Setting timeout to -1 will make GRUB wait infinitely.

By that I mean that you will be required to manually select an entry and hit Enter before launching any OS.

share|improve this answer

When running update-grub a warning says that setting grubtimeout to a non zero number is no longer supported. No matter what I changed the grub timeout value to timeout stayed at 10. If you are having this problem the workaround is editing the grub.cfg file located in /boot/grub. Near the end the script says IF TIMEOUT = 0 then timeout= 10. Change 10 to -1. No more countdown.

  1. gksu gedit /boot/grub/grub.cfg

  2. Find the part of the script around the end that says IF TIMEOUT = 0 then timeout= 10. Change 10 to -1.

This is a workaround it will be reverted if update-grub is ever run. Not permanent unless update-grub is not manually run.

(Works on 14.04.)

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.