Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

Possible Duplicate:
How can I get my graphics card to be recognized in System Info?

I've installed nvidia current (it works mostly) but the details section of the system settings shows that my driver is standard and the version is unknown. I'm getting a lot of errors and compiz has crashed at least twice.

Any help? What other information should I provide?

share|improve this question

marked as duplicate by Anwar Shah, Jorge Castro, Eliah Kagan, Mitch, Stephen Myall Oct 3 '12 at 8:14

This question has been asked before and already has an answer. If those answers do not fully address your question, please ask a new question.

    
You said "installed Nvidia current",Right?.How did you install it? By "Additional Drivers" option? If so,make sure to install the one "recommended". –  beeju May 12 '12 at 17:57
    
Yes I installed the recommended version through the driver gui originally but it gave me a black screen. So I purged the driver and reinstalled through the terminal with: sudo apt-add-repository ppa:ubuntu-x-swat/x-updates; sudo apt-get update; sudo apt-get install nvidia-current –  Colton Allen May 12 '12 at 17:59

3 Answers 3

I had the same problem, now doing all the updates after I checked all the configuration you showed through the software sources, which I had to find first (was not visible) and I did thanks to this link.

I did all the updates, still graphics unknown. don't know what else to do, I tried everything, NVIDIA has a massive issue here with ubuntu.

if you get the updates someone recommend you end up with a 640x480 resolution, then you have the xorg problem, seems there's no solution to this problem.

share|improve this answer

I changed my software sources settings to reflect the settings given. To do this I had to change the download from setting on the ubuntu software tab from 'netherlands' to 'Main server'. In addition to this I had to check the pre released updates (precise-proposed) check box on the updates tab. This gave an additional 60 updates but none of these mentioned nvidia. I installed them anyhow and a reboot was requested. After this reboot there are still no proprietary drivers found and the graphics information in the settings still says 'Driver Unknown, Experience Standard'

update:

the problem is mostly solved by performing the steps found on: mygeekopinions.blogspot on how to install nvidia drivers

sudo add-apt-repository ppa:ubuntu-x-swat/x-updates
sudo apt-get update
sudo apt-get install nvidia-current

After a reboot the additional drivers dialog shows the nvidia proprietary drivers. The graphic settings section of the all settings details window however still shows 'Driver unknown, Experience Standard'.

share|improve this answer
2  
Welcome to Ask Ubuntu! You've posted this as an answer, but it's not an attempt to answer the original poster's question, so it may be deleted soon. It looks like you have a separate, related question about how to get this to work on your machine. If that is the case, you should post a new question. You may also want to "star" this question, to be notified of any new answers. Alternatively, if this is intended as an answer, you may want to reword it so that this is clear. –  Eliah Kagan Jun 22 '12 at 11:15

Just enter

sudo apt-get install mesa-utils

and voila, it shows it as recognized.

share|improve this answer
1  
Firstly welcome to the AskUbuntu site! To further help the original poster of the question above I'd add more useful information to complement your answer if possible. –  Oyibo Sep 26 '12 at 21:25

Not the answer you're looking for? Browse other questions tagged or ask your own question.