Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I'm trying to stop Nautilus from creating thumbnails of PDF files. In another thread on 'Ubuntu forums' someone said to open gconf-editor and disable the PDF entry in the '/desktop/gnome/thumbnailers' directory. However the only entry in that DIR is disable all. Needless to say I don't want that.

How can I disable the thumbnails for a specific file type?

share|improve this question

2 Answers 2

up vote 10 down vote accepted

Thumbnails of specific file types can be disabled using dconf editor.

Install dconf editor:

Hit Alt+Ctrl+T and run the following command:

sudo apt-get install dconf-tools

Or search for "dconf-tools" in Software Center and install it from there.

How to disable thumbnails of specific file type?

  • Once installed, Hit super key (windows key) to open Unity dash and search for "dconf editor" and open it.

  • Navigate to org > gnome > desktop > thumbnailer

  • Paste the MIME type of PDF 'application/pdf' in the value field of disable key, Like shown below.

enter image description here

This will prevent Nautilus from generating thumbnails of PDF's in the future but old thumbnails will be there. To solve this you'll have to clear Nautilus thumbnail cache.

  • Open your home directory and Hit Ctrl+H to show the hidden files and folders.
  • Open .thumbnails and delete all the files in it.

  • Restart your system or kill Nautilus for change to take effect.

To disable thumbnails for other file types, Add there MIME type in disable list as described above. Seprate multiple types with comma. like this:

['application/pdf','image/jpeg','video/mp4']

For complete list of MIME types visit iana.org.

share|improve this answer
    
Excellent answer thanks! –  JeevesWeevil May 13 '12 at 15:01
    
Is there a way to exclude (for example) all video types without writting them all ? I tried ['video/*'] but it doesn't work. –  user55822 Sep 18 '12 at 9:21

To make stop from thumbnailing any video file (because in my little HTPC, it's causing high CPU usage):

Before, clean the thumbnail cache:

rm -rf ~/.cache/thumbnails

Apply the mime type list:

gsettings set org.gnome.desktop.thumbnailers disable "['application/annodex','application/mp4','application/ogg','application/vnd.rn-realmedia','application/x-matroska','video/3gpp','video/3gpp2','video/annodex','video/divx','video/flv','video/h264','video/mp4','video/mp4v-es','video/mpeg','video/mpeg-2','video/mpeg4','video/ogg','video/ogm','video/quicktime','video/ty','video/vdo','video/vivo','video/vnd.rn-realvideo','video/vnd.vivo','video/webm','video/x-bin','video/x-cdg','video/x-divx','video/x-dv','video/x-flv','video/x-la-asf','video/x-m4v','video/x-matroska','video/x-motion-jpeg','video/x-ms-asf','video/x-ms-dvr','video/x-ms-wm','video/x-ms-wmv','video/x-msvideo','video/x-sgi-movie','video/x-tivo','video/avi','video/x-ms-asx','video/x-ms-wvx','video/x-ms-wmx']"

Then to make sure:

nautilus -q

I get the mime type list from here.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.