Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

When I plug the external monitor up to my netbook it isn't found. I restart with them connected and it displays on the external monitor, but in the wrong resolution, shifted ~100 pixels to the right, and in a slightly brownish hue. I've tried using xrandr but it always gives me an error stating that

xrandr: Failed to get size of gamma for output default

The netbook's original monitor has the resolution of 1024x600 (16:9) and the monitor has 1600x900(16:9), but when I restart with them connected the default resolution of the netbook itself changes to 1024x768(4:3).

Does anyone know how to fix this problem? I have an integrated Intel chip if that helps.

share|improve this question
1  
Congrats on getting it solved, can you add that as an answer? - a step by step guide will help others :) –  fossfreedom May 12 '12 at 21:59
add comment

1 Answer 1

OP answered:

Ended up using arandr, a gui for xrandr, and almost fixed it, the rest is likely a driver problem.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.