Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I just finished upgrading my ubuntu

I had eclipse installed from terminal using apt-get install eclipse

Now I'm getting the following error

An error has occurred. See the log file /home/toluwanimi/.eclipse/org.eclipse.platform_3.7.0_155965261/configuration/1336830746877.log.

Please how do I go fix this

I've tried most of the fixes on this site but they don't seem to work for me

Here's the log

!SESSION 2012-05-12 14:52:26.563 -----------------------------------------------
eclipse.buildId=I20110613-1736
java.version=1.7.0_02
java.vendor=Oracle Corporation
BootLoader constants: OS=linux, ARCH=x86_64, WS=gtk, NL=en_GB
Command-line arguments:  -os linux -ws gtk -arch x86_64

!ENTRY org.eclipse.osgi 4 0 2012-05-12 14:52:29.469
!MESSAGE Application error
!STACK 1
java.lang.UnsatisfiedLinkError: Could not load SWT library. Reasons:
        no swt-gtk-3740 in java.library.path
        no swt-gtk in java.library.path
        Can't load library: /home/toluwanimi/.swt/lib/linux/x86_64/libswt-gtk-3740.so
        Can't load library: /home/toluwanimi/.swt/lib/linux/x86_64/libswt-gtk.so

        at org.eclipse.swt.internal.Library.loadLibrary(Library.java:285)
        at org.eclipse.swt.internal.Library.loadLibrary(Library.java:194)
        at org.eclipse.swt.internal.C.<clinit>(C.java:21)
        at org.eclipse.swt.internal.Converter.wcsToMbcs(Converter.java:63)
        at org.eclipse.swt.internal.Converter.wcsToMbcs(Converter.java:54)
        at org.eclipse.swt.widgets.Display.<clinit>(Display.java:132)
        at org.eclipse.ui.internal.Workbench.createDisplay(Workbench.java:695)
        at org.eclipse.ui.PlatformUI.createDisplay(PlatformUI.java:161)
        at org.eclipse.ui.internal.ide.application.IDEApplication.createDisplay(IDEApplication.java:153)
        at org.eclipse.ui.internal.ide.application.IDEApplication.start(IDEApplication.java:95)
        at org.eclipse.equinox.internal.app.EclipseAppHandle.run(EclipseAppHandle.java:196)
        at org.eclipse.core.runtime.internal.adaptor.EclipseAppLauncher.runApplication(EclipseAppLauncher.java:110)
        at org.eclipse.core.runtime.internal.adaptor.EclipseAppLauncher.start(EclipseAppLauncher.java:79)
        at org.eclipse.core.runtime.adaptor.EclipseStarter.run(EclipseStarter.java:344)
        at org.eclipse.core.runtime.adaptor.EclipseStarter.run(EclipseStarter.java:179)
        at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
        at sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:57)
        at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:43)
        at java.lang.reflect.Method.invoke(Method.java:601)
        at org.eclipse.equinox.launcher.Main.invokeFramework(Main.java:622)
        at org.eclipse.equinox.launcher.Main.basicRun(Main.java:577)
        at org.eclipse.equinox.launcher.Main.run(Main.java:1410)
        at org.eclipse.equinox.launcher.Main.main(Main.java1386)
share|improve this question
    
What is in the log file? –  desgua May 12 '12 at 14:12
    
wait a second.. –  Prosenik May 12 '12 at 14:15
1  
Make sure you have 64 bit Eclipse and 64 bit java or 32 bit Eclipse and 32 bit java as suggested here: bugs.debian.org/cgi-bin/bugreport.cgi?bug=663734 –  desgua May 12 '12 at 14:31
    
@desgua you should propose your comment as a potential answer :) –  Huygens May 12 '12 at 14:35
    
I had the same problem , see askubuntu.com/a/128263/4937 –  Binarylife May 12 '12 at 14:57
show 1 more comment

3 Answers

have you installed different versions of java rather than 1.7.x? it may be confused to eclipse, just see this link to re-configure your java environment.

To fix, open up terminal and type

sudo update-alternatives --config java

http://stackoverflow.com/questions/10165693/ubuntu-eclipse-cannot-load-swt-libraries-not-opening

In addition, I recommend install java and eclipse with self-extract files, it's easy to re-configure and can have multiple versions of them. Hope it helps.

share|improve this answer
    
thanks, I have 3 java alternatives - switching to another as the preferred on worked - Thanks all –  Prosenik May 12 '12 at 15:01
    
yeah, also , keep in mind that you can put a 32bit jdk on 64 bit linux and also run the 32bit eclipse. that is what I do. of course, you have to fiddle with alternatives to make that work though. –  djangofan May 12 '12 at 16:21
add comment
cd ~/.swt/lib/linux/x86_64
ln -s /usr/lib/jni/libswt-atk-gtk-3740.so
ln -s /usr/lib/jni/libswt-gtk-3740.so
ln -s /usr/lib/jni/libswt-pi-gtk-3740.so

I created three symlinks in the folder ~/.swt/lib/linux/x86_64

Now Eclipse is working.

share|improve this answer
add comment

Try with this command:

ln -s /usr/lib/jni/libswt-* ~/.swt/lib/linux/x86_64/ 
share|improve this answer
1  
What is supposed to do this? –  Lucio Sep 7 '13 at 19:12
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.