Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I am on 12.04 64bit, on 3 monitors, 12.3 fglrx drivers and use Libreoffice 3.5.3 (Ubuntu repositories). The menus of Libreoffice seem to open on the wrong screen. It seems this is an old bug, but i have only noticed it when ubuntu updated Libreoffice to 3.5.3. Previously everything was OK. Every other application behaves OK.

This issues has been reported in bugzilla http://listarchives.libreoffice.org/global/users/msg18576.html and launchpad https://bugs.launchpad.net/ubuntu/+source/libreoffice/+bug/974900

Does anyone knows if there is a workaround? This bug prevents me from using LibreOffice.

share|improve this question
    
One workaround is to install lo-menubar so that the menus show on the unity bar and not in the libreoffice windows –  ECII May 13 '12 at 10:17
    
I'm experiencing the same problem. Installing lo-menubar doesn't work for me. The only "fix" I've found so far is to disable my 2nd monitor. –  Jack Kelly May 13 '12 at 10:32
    
It looks like the relevant bug in LibreOffice's bugzilla is bugs.freedesktop.org/show_bug.cgi?id=48168 –  Jack Kelly May 13 '12 at 11:05
    
This is a very annoying bug. Is there something to do to get attention on it? It practically renders LO useless in multi-monitor systems. –  ECII May 13 '12 at 15:38
    
I'm not sure, I'm afraid. Have you added a comment to the LibreOffice bugzilla thread linked to above? I assume that the more people who comment on a bug, the more likely it is to get noticed by the developers. –  Jack Kelly May 14 '12 at 11:55

3 Answers 3

up vote 3 down vote accepted
+50

The LibreOffice bug report hasn't received any official updates for a while so I've done some tinkering. It turns out that uninstalling "libreoffice-gtk" fixes the menu problem for me (but LibreOffice looks rather ugly without GTK+ integration so this should be viewed as an ugly hack rather than a satisfactory fix... but at least it works)

share|improve this answer
    
Just as you said. A great ugly hack. But thank you very much. If nothing else comes up, the answer and bounty is yours. –  ECII May 21 '12 at 10:37
1  
You're welcome! If you're after a better fix, and if you've got some time to tinker, then it may be worth tinkering with compiling LO from source and trying different compilation options. The relevant bug report over on Gentoo's bugzilla suggests that re-compiling LO with different compilation options may fix it: bugs.gentoo.org/show_bug.cgi?id=408793 –  Jack Kelly May 21 '12 at 14:49
1  
Or perhaps the bug is with GTK+, in which case maybe you could re-compile LO with a different version of GTK+ linked in somehow –  Jack Kelly May 21 '12 at 14:56

There are two possible workarounds:

  1. With the menu Slideshow->Slideshow Settings, you can open a dialog which allows you to select the monitor manually at the bottom
  2. Since 3.5 the presenter-console has a "exchange screens" quick-button: http://wiki.documentfoundation.org/ReleaseNotes/3.5 To use presenter-console you need to: apt-get install libreoffice-presenter-console
share|improve this answer
1  
I am not talking about Impress. This issue happens in all LibreOffice programs, Calc, Writer etc etc –  ECII May 20 '12 at 13:15

Seems that this issue has been now fixed in LO 3.5.5 installed from the PPA.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.