Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I've installed the Ubuntu restricted area packages tried several things but no DVD play. AUDIO CD works fine, I built this system especially for linux all new hardware. dvd drive worked fine in a windows system. could it be a hardware issue, perhaps the drive having no specific name brand such as sony or lite on?

share|improve this question

3 Answers 3

try installing libdvdcss

Open Terminal and paste this

sudo -E wget --output-document=/etc/apt/sources.list.d/medibuntu.list http://www.medibuntu.org/sources.list.d/$(lsb_release -cs).list && sudo apt-get --quiet update && sudo apt-get --yes --quiet --allow-unauthenticated install medibuntu-keyring && sudo apt-get --quiet update

and Enter

then

sudo apt-get install app-install-data-medibuntu apport-hooks-medibuntu

now

sudo apt-get install libdvdcss

you should no be able to play DVDs

hope this helps

share|improve this answer

The problem might also be that the DVD is encrypted.

You need the libdvdread4 package which should be installed in Ubuntu 12.04 but which must be configured to work. Run this command in a Terminal

sudo /usr/share/doc/libdvdread4/install-css.sh

and try to play the DVD again.

You can get some more infos here in the official Ubuntu wiki.

share|improve this answer

A handful of drive manufacturers enforce regioning at the hardware level, which was the problem I had on my MacBook. If the above answers don't work, you can investigate your drive to see if this is the situation.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.