Ask Ubuntu is a question and answer site for Ubuntu users and developers. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I installed 12.04 today.
It worked on 11.10.

Now if headphones was plugged in on startup, they works, but if I unplug it, speakers don't work.
If headphones wasn't plugged before startup, sound is in speakers and in headphones at the same time.

Laptop is Acer aspire 5930.

Card: HDA Intel
Chip: Nvidia MCP77/78 HDMI

riad@riad-laptop:~$ cat /proc/asound/pcm 
00-00: ALC888 Analog : ALC888 Analog : playback 1 : capture 1
00-01: ALC888 Digital : ALC888 Digital : playback 1
00-02: ALC888 Analog : ALC888 Analog : capture 1
00-03: HDMI 0 : HDMI 0 : playback 1

Same problem in 12.10dev

Which additional info should I provide?

share|improve this question
up vote 3 down vote accepted

As ALC1200 and ALC888 seem to be very similar (see this German Wiki Entry) you can try my solution for the Intel HDA ALC1200 on my Acer Aspire 5920 G laptop. After upgrading to Ubuntu 12.04 Precise Pangolin from 11.10 my speakers continued to output the sound when plugging in headphones. In 11.10 the speakers were muted automatically when a headphone was plugged in.

I fixed it by adding a line to /etc/modprobe.d/alsa-base.conf :

options snd-hda-intel model=auto probe_mask=1

Now I've got a lot more options/controls when running alsamixer. One is "Auto-Mute Mode". Set this to "Enabled" if it does not work out of the box.


share|improve this answer
Thanks it works, even without using alsamixer – RiaD May 25 '12 at 18:04

Have paid attention for the same problem few minutes ago on my Acer 5920 (Intel HDA ALC1200), and hda-jack-retask utility that I've found here seems to have solved my problem. There are some comments about working ALC888 too.

share|improve this answer

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.