Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

After I installed Ubuntu 12.04, there are no sound at all on my headphone (rear jack panel).

On Sound settings > playback, it seemed that the sounds were detected after I choose 'play sound'.

Anybody can fix this issue??

Thanks.

share|improve this question
add comment

11 Answers 11

https://help.ubuntu.com/community/SoundTroubleshootingProcedure

I just did Step 1 and then reboot my laptop and the sound works.

Transcription if the link does not work

If you are using Ubuntu 12.04, then execute this command and reboot:

sudo add-apt-repository ppa:ubuntu-audio-dev/ppa; sudo apt-get update;sudo apt-get dist-upgrade; sudo apt-get install linux-sound-base alsa-base alsa-utils gdm ubuntu-desktop  linux-image-`uname -r` libasound2; sudo apt-get -y --reinstall install linux-sound-base alsa-base alsa-utils gdm ubuntu-desktop  linux-image-`uname -r` libasound2; killall pulseaudio; rm -r ~/.pulse*; sudo usermod -aG `cat /etc/group | grep -e '^pulse:' -e '^audio:' -e '^pulse-access:' -e '^pulse-rt:' -e '^video:' | awk -F: '{print $1}' | tr '\n' ',' | sed 's:,$::g'` `whoami`

Introduce the whole paragraph in your terminal and it should work. I hope it helps you. For new users, the terminal will run a whole load of commands, do not worry! it will work (well it did for me).

share|improve this answer
    
thank you so much. This problem take me a long time to find solutions. –  Kien Thanh Jun 13 '13 at 19:56
add comment

Try this:

sudo killall pulseaudio
sudo alsa force-reload
share|improve this answer
add comment

Have you been muted? For pulseaudio, try pavucontrol, and check if the mute button is on in the Output Devices tab:

mute pic

share|improve this answer
    
its a little wierd but i just canged the port (on the picture) and it worked! hope it helps :) –  user64435 May 18 '12 at 13:57
add comment

Whatever you do don't enter the huge code on the first answer! It completely ruined my login screen.

Just use killall pulseaudio in the terminal.

share|improve this answer
add comment

I had the same issue, I ended up plugging my speakers into the rear audio out and it worked. On the sound test under "stereo mode" the front left/right works, but when I put it in 5.1, my speakers are converted to the rear channels like they are supposed to be. So I just leave it in stereo (that's what they are anyways).

Although, if you have a laptop or "non-HD audio" hardware (only a line in, line out, mic), this won't be possible.

Also, the strange thing was my front panel audio works fine, must be something goofy with the Realtek HD audio drivers...

share|improve this answer
add comment

I was having the same issue as the OP for a little while and I finally figured it out.

Check your BIOS and make sure that your onboard audio is set to Enabled. Not Auto or Disabled. Mine was on auto and nothing would make 12.04 see the device.

share|improve this answer
add comment

This is what fixed it for me.

Open terminal

sudo gedit /etc/modprobe.d/modprobe.conf

A new file will be opened, write a line below then save.

options snd_hda_intel model=mb5

Close file Reboot the computer.

Thanks to No sound on an iMac

share|improve this answer
add comment

This did not work for my case Ubuntu AMD 64 12.04 with HP quad core PC 5GB ram. Other issues existed and sound disappeared after updates and other software install. May have had a script bug as well? Located odd files and delited from home page. found that Kubuntu driver for the PC using the DVD ISO was NVidea MCP61 used sudo apt-get install Nvidea MCP61

Located synaptic files that were broken and tried to fix them. Un installed or removed one, installed another, updated the third file.

Turned of PC and restarted after waiting for updates and upgrades to install. The next day the sound setting are back to normal and the Dummy output setting is gone.

share|improve this answer
1  
This doesn't really answer the question as you don't say anything specific to guide the OP. –  RolandiXor Sep 25 '12 at 19:35
add comment

In a terminal, I ran gstreamer-properties, forced both input and output to ALSA Advanced Linux Sound Architecture, and rebooted. Then it worked fine!

share|improve this answer
add comment

Try to read this: Skype FAQ - sound system change

share|improve this answer
add comment

Okey. I see your problem. I had it too. Try this. It's safe and worked for me.

Open the terminal and type

alsamixer

Press S and select the HD-Audio Generic option. Scroll to automute and disable it now turn up all the volume options Press Esc to exit

Done!

Now try and play something Best of luck ;) :D

share|improve this answer
add comment

protected by gertvdijk Oct 13 '13 at 19:13

Thank you for your interest in this question. Because it has attracted low-quality answers, posting an answer now requires 10 reputation on this site.

Would you like to answer one of these unanswered questions instead?

Not the answer you're looking for? Browse other questions tagged or ask your own question.