Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

Ubuntu 12.04 uses a nice little automagic dnsmasq configuration for handling name resolution across DNS connections so that name resolution happens properly.

When I connect to my OpenVPN server at work (for which I am the administrator) the client recognizes the reverse lookup networks properly and puts lines for those into the dnsmasq config, but not the forward networks:

/var/run/nm-dns-dnsmasq.conf:
server=/10.in-addr.arpa/192.168.0.5
server=/0.168.192.in-addr.arpa/192.168.0.5
server=192.168.1.3

The contents should be:

server=/workdomain.ca/192.168.0.5
server=/10.in-addr.arpa/192.168.0.5
server=/0.168.192.in-addr.arpa/192.168.0.5
server=192.168.1.3

What do I need to change on my OpenVPN server (pfsense) to push one or more search domains to the VPN client?

share|improve this question
add comment

1 Answer

up vote 1 down vote accepted

Hmm, my client doesn't recognize the domains correctly and just uses the one DNS server my VPN server pushses rather than only using my VPN DNS for VPN domains. To answer your question though, look into using push "dhcp-option DOMAIN example.com"

share|improve this answer
1  
This solves the immediate problem, though I'm still left with the question of how to add more than one domain. –  MikeyB May 28 '12 at 14:27
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.