Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I have an ODBII USB cable for vehicle diagnostics, unfortunately I haven't been able to get it working on Ubuntu 12.04. The closest I've come is using the VAG-COM software with wine, using the ln -s /dev/ttyUSB0 ~/.wine/dosdevices/com1 trick and running stty -F /dev/ttyUSB0 speed 9600 repeatedly. It will connect and show the vehicle is OBDII, but none of the useful features seem to be working. I tried:

  • Scantool - says it's connecting to the /dev/device in terminal, but doesn't.
  • obdgpslogger - times out all the time.
  • pyobd - This seems to be the most up-to-date source I could find, I had to adjust the code a bit to work (see here for changes). Still, in obd_io.py interpret_result function, it says it's looking for 4 space separated numbers, where the usb-serial is receiving bogus code "0100" instead?
  • freediag - I tried compiling, sh ./configure ran fine. I had to change some executable bit to make it start to compile, but now running make gives error:

    diag_general.c:52: undefined reference to diag_l0_config' diag_general.c:55: undefined reference todiag_l2_config' collect2: ld returned 1 exit status ...

    and fails.

The device shows up in lsusb as:

ID 0403:6001 Future Technology Devices International, Ltd FT232 USB-Serial (UART) IC

Is the problem that these native tools don't expect a USB serial, or a serial of this type? Or are these apps too old to recognize OBD2 of this vehicle?

share|improve this question

2 Answers 2

Reference Data 1.This cable can not work if your car uses a protocol ssystem like VPW,PWM or Can-bus

This is a direct copy/paste from the Amazon page for the cable you link to. It may be that the cable just doesn't work with your device, though I would think the programs should see a non-working cable attached.

Have you also tried Freediag?

share|improve this answer
    
I don't know of any vehicles with CAN/VPW/etc, mine is OBDII (the cable has "OBDII" embedded into the car end). I tried Freediag, but it wouldn't compile. See updated info in question. –  NoBugs Jun 12 '12 at 18:19
1  
OK. So, OBD-II isn't a protocol, itself. There are multiple protocols which fall under the OBD-II standard. If your vehicle is a US vehicle newer than 2008, it's almost certainly using CAN. If it's older, it may or may not be using it. See en.wikipedia.org/wiki/… for some more info. What year/make/model is the vehicle you're attempting to use it with? –  dobey Jun 12 '12 at 19:06
    
Good find! I didn't know there were different protocols. The diagnostics connector has 6 wires connected, three are together. –  NoBugs Jun 13 '12 at 3:06
    
Pins 1, 6, 10, 12, 13, and 14 have wires going from the diagnostics port. This page doesn't list the protocol: auterraweb.com/obdiipinout.html Furthermore, the manual makes no mention of OBD. –  NoBugs Jun 13 '12 at 3:16
    
Those pins are on the cable side, or in your vehicle? What year/make/model is the car? –  dobey Jun 13 '12 at 3:50

Try these resources:

Using ScanTool(win) under Linux using Wine

Ubuntu Forums: OBDII Code Readers COM1 Port

share|improve this answer
    
That windows tool, Scantool is the same program as the one in Ubuntu repository, except it doesn't even list COM ports to select! –  NoBugs Jun 7 '12 at 1:52

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.