Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I have a dual boot (actually triple with windows but that's irrelevant) with Ubuntu 12.04 [1] and another Ubuntu [2]. I recently upgraded [2] which may have overwritten [1]'s grub with [2]'s grub, ie [2] is top of the list and background color previously changed is back to purple. [1] being my main OS, Id like [1]'s grub back :(

Im well aware of the windows-ubuntu MBR issue that can be fixed by reinstalling grub 2. Im just asking if there's a simpler way when it's about 2 ubuntus. What could I do knowing that I have access to all OS' ?

PS: sudo update-grub in [1] isn't enough ...

share|improve this question
    
Good question. +1. I have a similar setup in mind for one of my machines, will bookmark your question. –  0xC0000022L May 11 '12 at 23:25
    
I noticed the command you executed is 'sudo grub-update'. It should be 'sudo update-grub'. –  J. Austin Rodriguez May 11 '12 at 23:37
    
@zeroseven0183, that's what I meant, edited, thanks. –  user50745 May 12 '12 at 0:02

1 Answer 1

up vote 2 down vote accepted

sudo grub-install /dev/sdX (where "sdX" is something like "sda", not a partition like "sda1".

You can also disable the running of grub-install by Ubuntu #2's grub-pc package by removing all install devices. With versions of Ubuntu before 12.04 this can be done by running sudo dpkg-reconfigure grub-pc and selecting the defaults for the linux cmdline questions then using space bar to deselect any selected devices, and hit return to continue. For doing the same in Ubuntu 12.04 see How should one set the grub-pc package's "install_devices" debconf setting in Ubuntu 12.04? (which is unanswered as of this writing).

share|improve this answer
    
Simple enough. Thanks for pointing me to grup-pc. It's now answered but not accepted so I'll just say sudo dpkg-reconfigure grub-pc works for me. Thanks again. –  user50745 May 12 '12 at 7:59

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.