Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I have a VPS set up with Ubuntu 12.04 on it and am having trouble getting a second IP set up as a virtual interface. I've configured the interface as you can see from my /etc/networking/interfaces file here:

# The loopback network interface
auto lo
iface lo inet loopback

# Interfaces brought up durring boot
auto eth0 eth0:0 eth0:1

# eth0 - Public IP, WAN access
iface eth0 inet static
    address 72.14.191.251
    netmask 255.255.255.0
    gateway 72.14.191.1

# eth0:0 - Public IP, WAN access
iface eth0:0 inet static
    address 173.255.199.148
    netmask 255.255.255.0
    gateway 173.255.199.1

# eth0:1 - Private IP, LAN access
iface eth0:1 inet static
    address 192.168.128.46
    netmask 255.255.128.0

The interface in question is eth0:0 with the IP of 173.255.199.148, no connection can be made to that IP. I can't even ping it. If I run ifconfig, all interfaces show as up:

eth0      Link encap:Ethernet  HWaddr f2:3c:91:ae:a0:8b  
          inet addr:72.14.191.251  Bcast:72.14.191.255  Mask:255.255.255.0
          inet6 addr: 2600:3c00::f03c:91ff:feae:a08b/64 Scope:Global
          inet6 addr: fe80::f03c:91ff:feae:a08b/64 Scope:Link
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
          RX packets:3664 errors:0 dropped:0 overruns:0 frame:0
          TX packets:2908 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000 
          RX bytes:330670 (330.6 KB)  TX bytes:970665 (970.6 KB)
          Interrupt:44 

eth0:0    Link encap:Ethernet  HWaddr f2:3c:91:ae:a0:8b  
          inet addr:173.255.199.148  Bcast:173.255.199.255  Mask:255.255.255.0
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
          Interrupt:44 

eth0:1    Link encap:Ethernet  HWaddr f2:3c:91:ae:a0:8b  
          inet addr:192.168.128.46  Bcast:192.168.255.255  Mask:255.255.128.0
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
          Interrupt:44 

lo        Link encap:Local Loopback  
          inet addr:127.0.0.1  Mask:255.0.0.0
          inet6 addr: ::1/128 Scope:Host
          UP LOOPBACK RUNNING  MTU:16436  Metric:1
          RX packets:135 errors:0 dropped:0 overruns:0 frame:0
          TX packets:135 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:0 
          RX bytes:141948 (141.9 KB)  TX bytes:141948 (141.9 KB)

Trying to bring the interface down or up doesn't help either:

chris@Optimus:~$ sudo ifdown eth0:0
ifdown: interface eth0:0 not configured
chris@Optimus:~$ sudo ifup eth0:0
RTNETLINK answers: File exists
Failed to bring up eth0:0.

Nor does restarting networking:

chris@Optimus:~$ sudo /etc/init.d/networking restart
 * Running /etc/init.d/networking restart is deprecated because it may not enable again some interfaces
 * Reconfiguring network interfaces...                                                                                                                                                                                                         resolvconf: Error: /etc/resolv.conf isn't a symlink, not doing anything.
resolvconf: Error: /etc/resolv.conf isn't a symlink, not doing anything.
resolvconf: Error: /etc/resolv.conf isn't a symlink, not doing anything.
ssh stop/waiting
ssh start/running, process 4289
RTNETLINK answers: File exists
Failed to bring up eth0:0.
resolvconf: Error: /etc/resolv.conf isn't a symlink, not doing anything.
ssh stop/waiting
ssh start/running, process 4361

Even a complete system reboot did nothing. What is the problem here? What am I missing?

share|improve this question
    
Where are you trying to ping from? What is the output to netstat -rn? –  jippie May 11 '12 at 22:16
add comment

closed as off-topic by jokerdino Jan 7 at 17:37

This question appears to be off-topic. The users who voted to close gave this specific reason:

  • "This describes a problem that can't be reproduced that seemingly went away on its own or was only relevant to a very specific period of time. It's off-topic as it's unlikely to help future readers." – jokerdino
If this question can be reworded to fit the rules in the help center, please edit the question.

2 Answers

chris@Optimus:~$ sudo ifdown eth0:0
ifdown: interface eth0:0 not configured
chris@Optimus:~$ sudo ifup eth0:0
RTNETLINK answers: File exists
Failed to bring up eth0:0.

Looks as if ifup was confused about the state of eth0:0. Easiest solution is to reboot.

resolvconf: Error: /etc/resolv.conf isn't a symlink

To fix this, run

sudo dpkg-reconfigure resolvconf
share|improve this answer
add comment
up vote 0 down vote accepted

I don't know what happened, but I rebooted the server one more time and it now seems to be working. I'm really confused, but at least it's working.

share|improve this answer
add comment

Not the answer you're looking for? Browse other questions tagged or ask your own question.