Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

This question already has an answer here:

Since upgrading to 12.04, my alt-tab occasionally does not work. I cannot determine the symptoms that lead to it, but there are some windows that just decide not to show. What happens is I alt-tab to a given window, say the terminal, and instead of showing it, I just see it wobble like a notification in the list of programs down the left. Is this a bug?

share|improve this question
    
Isn't this a bug, and so off-topic for the site? –  Tom Brossman Dec 4 '12 at 9:31
add comment

marked as duplicate by Eric Carvalho, raaz, aquaherd, Thomas W., Mitch May 11 '13 at 17:58

This question has been asked before and already has an answer. If those answers do not fully address your question, please ask a new question.

3 Answers

up vote 29 down vote accepted

Yes, I noticed that too! I'm surprised they forgot something as important as that.

Install Compiz Config Settings Manager:

To open terminal hit Alt+Ctrl+T and run following commands:

sudo apt-get install compizconfig-settings-manager

Or search for compizconfig-settings-manager in Software Center and install from there.

Then go to system tools > preferences > compizconfig

Go at the very bottom where it says windows management (or something similar to that, my distro is in french)

Put a checkmark in application switcher

That should fix it.

go to system tools > preferences > compizconfig Then, Windows Manager-Application Switcher. click on Next window-alt-tab click it. click on ''Grab key Combination'',here actually use alt+tab, & it will grab it. OK

share|improve this answer
2  
Work great! But it is totally crazy! How could I have figured it out from nowhere?... –  Mike Aski Jun 13 '12 at 8:47
1  
Unfortunately this didn't work for me, not even in conjunction with disabling the Unity Switcher, but Gordon's suggestion did. –  Matthew Read Jul 13 '12 at 18:07
    
@Matthew Finally got it to work: in ccsm > Ubuntu Unity Plugin > Switcher, ensure <Alt>Tab is set for "Key to start the switcher", then "Back", then click the checkbox (to get it checked) near Ubuntu Unity Plugin - after a few warnings and key conflicts resolution, that should work! –  ring0 Oct 15 '12 at 5:31
    
Better yet for gnome classic users: when log in, just ensure (click the foot icon) to start Gnome classic No effects. The no-effect version seems to have Alt-tab working. –  ring0 Oct 15 '12 at 5:49
    
compiz crashes every time on my office computer, so i decided to not install it on my laptop. But I have some problems with alt+tab. sometimes some programs do not appear there or simply disappear –  Ricardo Martins Oct 17 '12 at 13:54
show 1 more comment

In case Application switcher, doesnt work (like the 1st answer), check the static application switcher in CCSM. It works fine for me.

share|improve this answer
add comment

I have Ubuntu 12.04 with gnome-classic (without effects, so no Compiz) and the above doesn't work.

The fix, from here is actually easier than you'd expect:

  • Go to 'Applications','System Tools','System Settings'
  • Click 'Keyboard'
  • Click the 'Shortcuts Tab'
  • Click 'Navigation' on the left
  • In the right-hand pane click on 'Switch applications' and press Alt-Tab to assign that as the accelerator.
share|improve this answer
    
Im also using gnome-classic, my shortcut for switch application is alt+tab and it still does not work... ? –  Piero Oct 11 '12 at 14:57
1  
Same problem here. –  ring0 Oct 15 '12 at 4:41
1  
It stopped working for me as well. I ended up removing .gconf* and .gnome2* folders - it started working. Proper fix would be to remove or edit one of the configuration files, but I do not have time to investigate –  Yevgen Yampolskiy Dec 3 '12 at 12:21
    
it works for me on VB Ubuntu –  Coc Dec 30 '12 at 4:51
add comment

protected by Community Jul 9 '12 at 11:43

Thank you for your interest in this question. Because it has attracted low-quality answers, posting an answer now requires 10 reputation on this site.

Would you like to answer one of these unanswered questions instead?

Not the answer you're looking for? Browse other questions tagged or ask your own question.