Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I've tested Ubuntu 12.04 from live usb before executing the automagic update (from 11.10 to 12.04) and everything was fine. Then, after updating, I couldn't even get Unity 2D to work. I've installed Gnome packages, so I can use Gnome classic (only the "with no effects" option works).

Does any one know how to debug Ubuntu/Unity to try to get it working? (Or I'll need to do a fresh install...)

share|improve this question
    
you could start by telling us in more detail what does work, what does happen, what you expect to happen. –  jippie May 11 '12 at 20:48
    
When I choose Unity in login screen and login, it starts oscillating from blackscreen to wallpaper first. Then, I get no left menu, no desktop icons... nothing clickable. Ubuntu crash report then executes, saying "Compiz closed unexpectedly". The title of the bug report's details is "Crash with SIGSEGV" –  YuriC May 11 '12 at 21:06
    
Does that bug report have any other information but a title? –  jippie May 11 '12 at 21:12
    
Are you choosing Unity 2D .... If not, please try that and report. –  barrydrake May 11 '12 at 21:14
    
@jippie, yes, a lot of information, but I cant copy it. I'll look for some more sensitive information. –  YuriC May 11 '12 at 21:21

2 Answers 2

up vote 2 down vote accepted

I've found out the solution. It is related to a NVIDIA's driver problem.

Looking for messages in /var/log/syslog, I've discovered an error message from which I've taken the main words:

segfault error 4 in libc-2.15.so compiz

A search on Google and I've found this post:

Compiz crashes with SIGSEGV after upgrade to 12.04

http://ubuntuforums.org/showthread.php?t=1966002&page=2

So, the problem is related to NVIDIAS's proprietary drivers. (There are two options from Additional Drivers, none of them works...) Disabling them brings me back the normal Unity, which unfortunately runs slowly, for obvious reasons. That's why I don't get this problem when I use the live usb: the proprietary drivers are not enabled by default.

Now, we've got to wait NVIDIA fix this issue...

share|improve this answer

If it were me, I'd do a clean install (but then this is what I actually did after a lot of work). Bit of advice you won't like: pleas try Unity for a week. I hated it, but persevered. Nothing would tempt me back to gnome now!!!!

share|improve this answer
    
Agree. Unity is starting to convince me. As long as it gets less buggy and smarter, typing for what we want and accessing it rapidly gets really interesting... I'd like Unity to be lighter. –  YuriC May 11 '12 at 21:17
    
I've been running it on my desktop since Alpha 1 and on my netbook since just before LTS release date. No bugs! If you are getting lots of bugs, this may be due to stuff carried over from 11.10 and that kind of problem can take forever to track down. –  barrydrake May 12 '12 at 10:47

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.