Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I've just installed and configured Ubuntu 12.04 on my machine. I've changed all font sizes, with the myunity tool, and they're now all set to the Ubuntu font size 9.

However, I can't find anywhere in Ubuntu a way to change the HUGE dash search/UI font. Any idea on where I can change it? Any dconf/gconf setting option?

Here are some screenshots, compare the size of the dash fonts to desktops apps.

Dash font: enter image description here

Desktop font: first screen

second screen

share|improve this question

5 Answers 5

up vote 4 down vote accepted
+100

Unfortunately, the current answer is: you cannot (unless you figure out and modify the source code).

In this answer, I list the ways which do not work, to save future reader-modders the time and trouble of trying and failing.

A. Existing bug report

  • Bug #756845 ("Unity dash search unable to change font/icon size") refers to this exact problem, as shown by part of the screenshot for the bug report:

    enter image description here

  • The bug has been confirmed and labeled "low importance", with no comments by developers or anyone else on a workaround or when it will be resolved.

B. Changing fonts or the scaling factor in gnome-tweak-tool

  • This does not work either:

    enter image description here

  • Changing the scaling factor appears to change everything BUT the dash/hud font size (that's a 1920x1080 screenshot below -- compare the terminal font size!):

    enter image description here

C. Editing dash-widgets.json in the Unity Theme folder

  • You can find a file called dash-widgets.json in /usr/share/unity/5/ and /usr/share/unity/themes. This contains a bunch of CSS-like settings that may give you hope, such as:

      "preview-heading-small"  : {
    "main-title-size"    : 23.0,

    but changing them does not work. (the Dash font is approximately size 22)

D. Changing the Launcher Icon size Doesn't Affect It

  • Since the dash text field is almost exactly the height of the Ubuntu launcher icon, you might think decreasing the icon size would change the height of the text field and make its font smaller.

    • Changing the icon size is easy from the Unity Plugin in CompizConfig Settings Manager (ccsm), or from its MyUnity frontend:

    enter image description here enter image description here

    • But decreasing to the minimum, 32, doesn't change the dash font size!

    enter image description here

share|improve this answer

A bug has been reported as "Unity dash search unable to change font/icon size" .

So right now you can not change tha default font size in dash search. you have to go with it :((

share|improve this answer
    
Correct - a bug report has been made - but this does not mean it is not possible. No response has been made as yet. This would be a better answer if you can point the OP to where in the unity code he should be looking to change/fix this. –  fossfreedom May 28 '12 at 6:03

Try tweaking the parameters in /usr/share/unity/5/dash-widgets.json.

share|improve this answer
3  
It would be preferable to give guidance as to what you need to change in this file to actually answer the question. –  fossfreedom May 27 '12 at 21:40
    
Yes, and sorry, as the correct answer indicates that file-settings does nothing, maybe it is there for future use. A little curious here, this file contains the style information, but most of the settings-related functions there seem to be returning constant values. Can that be the reason? –  Samik May 30 '12 at 10:22

Nah, go to MyUnity, click on the tab "Dash" and change Dash size to Desktop. I assume you have 12.04 though.

share|improve this answer

You can do this by installing the Gnome-tweak-tool and change the default font.

sudo apt-get install gnome-tweak-tool

enter image description here

share|improve this answer
    
it doesn't work :/ –  Marcos Roriz Junior May 12 '12 at 20:29
1  
@MarcosRoriz Did you try logging out and back in (or rebooting) after making the changes? –  Eliah Kagan May 27 '12 at 19:28
    
Yep! I tried that. No luck :( –  Marcos Roriz Junior May 29 '12 at 1:33

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.