Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I edited /etc/fstab to automount NTFS partition, then all file were marked "Allow executing file as program". How can I fix it?

EDIT: When I double click any text file, it didn't show immediately, a dialog was displayed, and I must choose Display option to view it in gedit.

share|improve this question
3  
Is there something to "fix"? NTFS has no conception of execute bit; nevertheless it is entirely possible for executable files (scripts, Unix executables, even Windows EXEs if you have Wine configured properly) to be present. –  geekosaur May 11 '12 at 16:49
    
This isn't necessarily a problem... –  SirCharlo May 11 '12 at 16:51
    
text file is example. When I double-click to a text file, a dialog is displayed, and I can choose "Run", "Display".... I saw it's propertity "Allow executing file as program" was checked. –  John Catter May 11 '12 at 16:53
    
But what's the problem with this behavior? –  SirCharlo May 11 '12 at 16:56
    
@SirCharlo: If I don't automount NTFS partition, I can open text file immediately (1 step). But now, I must double click, and then I must choose Display option (2 steps). –  John Catter May 11 '12 at 17:01

1 Answer 1

Add noexec to the options for that partition in your fstab.

share|improve this answer
    
@SirCarlo I think Adding more details will be helpful for new user. Can you edit it to include more details. –  Anwar Shah May 12 '12 at 14:16

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.