Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

Automatic login option is missing from System Settings > User Accounts, how can I solve this?

enter image description here

I either can't set the automatic login by editing /etc/lightdm/lightdm.conf

[SeatDefaults]

autologin-user=x

autologin-user-timeout=0

user-session=ubuntu

greeter-session=unity-greeter

After restart login screen asks for my password.

There is a thread in Ubuntu forums http://ubuntuforums.org/showthread.php?p=11889259 . It's in lubuntu forum, but there are ubuntu users afected too.

I'm runing 12.04 (precise) 64-bit with Kernel Linux 3.2.0-24-generic.

Excuse my bad english, please.

share|improve this question
    
Are you sure you 'Unlocked' the settings pane? (Top right) –  SirCharlo May 11 '12 at 15:40
    
Are you sure about this? When I go into my System Settings > User Accounts, I see a button called 'Automatic Login' that is set to OFF. –  ruffEdgz May 11 '12 at 15:42
    
I'm sure, I unlocked the settings pane. There is not a Automatic login button –  grossogrossum May 12 '12 at 0:57
    
see this image: bit.ly/KVhGmz just like grossogrossum said is unlocked (see rounded area) and pane ends in a passwd field I'm runing 12.04 (precise) 32-bit with Kernel Linux 3.2.0-24-generic-pae under a virtual box machine. –  user66489 May 27 '12 at 14:00
    
@grossogrossum: finaly, I have viewed the "Atomatic Login" option under my user account; starting a session with guest user, going to User Account and click my username. But activating it via gui doesn't allows to login automatically ... :( –  user66489 May 27 '12 at 21:05

2 Answers 2

The Automatic Login option won't appear if you have an encrypted home folder - both features contradict each other.

share|improve this answer
3  
So what do you suggest Daniel, for those who have an encrypted home folder? Is there a way around this? –  Mike Spy Oct 3 '12 at 20:43
1  
did you find out a solution? –  Totty Oct 11 '12 at 9:21

Well, it should "be there" for all users -- but you need to remember to click the unlock on the top-right before you can change it:

login lock

share|improve this answer
    
I'm not allowed to post an image (I'm new user) but my User Account pane ends in Password ******, and it's unlocked. –  grossogrossum May 12 '12 at 1:07

protected by Community Oct 3 '12 at 21:04

Thank you for your interest in this question. Because it has attracted low-quality answers, posting an answer now requires 10 reputation on this site.

Would you like to answer one of these unanswered questions instead?

Not the answer you're looking for? Browse other questions tagged or ask your own question.