Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I use Keyboard Input Methods program for inputting Tamil. I need to manually start it everytime I need to use it. How can I add it to start up?

I don't want it asking me this everytime I start it:

"Keyboard Input Methods (IBus Daemon) has not been started. Do you want to start it now?"

and also this dialog:

"IBus has been started! If you can not use IBus, please open System Menu -> System Settings -> Language Support and set the "Keyboard Input Method" to "ibus", then log out and back in again."

share|improve this question

4 Answers 4

You need to add ibus-daemon to your startup applications:

  • Open startup applications from the power cog
    powercog
  • Add ibus-daemon
    add-button
    add-dialog
share|improve this answer

I think a better way of enabling ibus should be the following

im-switch -s ibus

There is no need to manually add startup entry for ibus-daemon

share|improve this answer

Similar to the previous post adding ibus to Startup Applications..., I used

ibus-daemon --xim 

as in the file /usr/share/applications/ibus.desktop.

share|improve this answer

Have you tried setting the input method in System settings>Language support to ibus? It should automatically startup if the input method is set to ibus.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.