Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I have a Amazon Web Services Server with Ubuntu 11.10 installed I have insalled mono and i have successfully dployed ad launched a .NET webservice with xsp4. Now I want to host it on that server. I am trying to figure out how to set up Apache and mod_mono to use. I was told Apache is already installed by default. But I don't know where to find it. I am a complete Newbie with Linux!! Help Please!

share|improve this question
    
well I installed apache2 "sudo apt-get install apache2" –  greektreat May 11 '12 at 15:37
add comment

1 Answer

up vote 5 down vote accepted

This is probably what you want.

sudo apt-get install libapache2-mod-mono mono-apache-server2 

libapache2-mod-monoInstall libapache2-mod-mono mono-apache-server2Install mono-apache-server2


Here are some informative links that should help you get started.


Quick tip

If you're only searching for which package to install, try the following command:

sudo apt-cache search keyword-here

So for instance,

sudo apt-cache search mod_mono

Gives this:

asp.net-examples - demo pages for ASP.NET infrastructure
libapache2-mod-mono - Apache module for running ASP.NET applications on Mono
mono-apache-server - ASP.NET backend for mod_mono Apache module - default version
mono-apache-server2 - ASP.NET 2.0 backend for mod_mono2 Apache module
mono-apache-server4 - ASP.NET 1.1 backend for mod_mono Apache module

The first package mentionned is not necessarily relevant, but the other lines tell you which packages have something to do with mod_mono, and what they do exactly.

Hope this helps!

share|improve this answer
1  
Thanks, Before you responded I ran the command: sudo apt-get install libapache2-mod-mono. It went through and did what it needed. but now for the last hour I don't know what to do. it just said: Setting up mono-apache-server4 (2.10-1) ... * Reloading web server config apache2 [ OK ] * Restarting web server apache2 ... waiting . [ OK ] –  greektreat May 11 '12 at 17:11
2  
Yeah, I think it did that to me too (I did this a while back, memory's a bit foggy). I think i had opened a second terminal and issued the command sudo service apache2 reload; sudo service apache2 restart and apt had moved on after.. I think. –  SirCharlo May 11 '12 at 17:13
    
I'm almost there the apache seems to work and the folder is set up. I Deployed a asmx webservice and I try rowsing to it : xx.xxx.xxx.xxx/EmailChecker/CheckEmailAddress.asmx. and instead of showing me the web service. It downloaded the asmx file. how to I set it to be an page? –  greektreat May 11 '12 at 18:33
    
Ah! We're getting there :) This seems to be a problem with MIME types perhaps? What does ls /etc/apache2/mods-enabled/*mod_mono* say? Also, check out the post found here and see if it helps. –  SirCharlo May 11 '12 at 19:15
    
-bash: /etc/apache2/mods-enabled/mod_mono.conf: Permission denied –  greektreat May 11 '12 at 19:23
show 4 more comments

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.