Ask Ubuntu is a question and answer site for Ubuntu users and developers. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

OS: Ubuntu 12.04 Kernel: 3.3.5-030305-generic-pae Device: Dell Inspiron 1464.

Recently I am having a problem that is: I use a wimax device whose chipset is Beecem BCSM250 wimax. It is ZTE AX226 wimax modem. It is working fine on ubuntu 11.04.

But in 12.04 it works good but sometimes when i just insert this modem my screen goes full black & system gets hanged. Nothing is working. So i updated my kernel from 3.2.0-24generic to 3.3.5-030305-generic-pae manually by downloading deb files.

Now in this new kernel my wlan card is not working (Chipset: BCM4312) while it was running smoothly on my previous kernel. I tried fwcutter & firmware from software centre, but it didnt worked.

Now I need both wimax & wlan working on my pc. Plz help me guys i m in a big problem.....

lspci output:

03:00.0 Network controller: Broadcom Corporation BCM4312 802.11b/g LP-PHY (rev 01)

share|improve this question
up vote 2 down vote accepted

You should try searching around and finding out if there is a kernel that is known to work with your Wireless Card. If not, you can always use your older kernel one of two ways:

  1. Boot into older kernel. Depending on how your kernel was installed, you might be able to boot into your old one by holding down Shift as the computer boots, bringing up the Grub Boot menu. On this menu, there might be an option entitled "Previous Linux Versions" and inside that menu, you might find your 3.2.0-24 kernel as an option. If not, read on...
  2. Find a new kernel. If you can find a kernel that is confirmed working or even just a newer one to try out, you can try installing it from a downloaded DEB file. These can be found at the Ubuntu Packages Repository. The procedure for installing a kernel from downloaded DEB is well explained here

Hope that helps...

share|improve this answer
Is there any nice way to make the "Boot into older kernel" setting permanent? Like "ignore any 3.x kernels on upgrades"? – alfonx May 15 '12 at 11:56
To be honest, I'm not too sure. You could try changing the default GRUB option but since its in a submenu, I wouldn't know how to do that properly. – agc93 May 21 '12 at 3:05

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.