Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

After attempting to install Ubuntu Desktop 32bit on our HyperV environment - which requires static IP addressing, Ubuntu thinks the network cable is unplugged. It's connected to the correct Team NIC in SCVMM (like 40 or so other servers; which are all working fine) but for some reason it doesn't detect that the cable is "plugged in". I'm going to try Ubuntu Server 64-bit to see if that works.

UPDATE - looks like server has the same problem.

share|improve this question

4 Answers 4

I had a similar issue where the eth0 was showing lots of errors and dropped packets. I double checked the SCVMM Virtual Machine Properties and Network Adapter 1 was of the "Emulated" type. Once I set it to "Synthetic" (supported via hv_netvsc module compiled into Kernel 3.1) I was in business. I'm guessing that this is SCVMM's default when you select "Other Linux (64 bit)" during initial creation of the VM.

share|improve this answer

I have the same issue. However, I tried to install 12.04 server 32-bit and that worked with no problem. It seems, for me anyway, that this is an issue with the 64-bit version. I'm running the stand alone Hyper-V 2008 server on an HP Proliant DL360 Gen8.

share|improve this answer

In our case helped: unchecked "enable virtual machine queue" and disable ipsec (both in hardware acceleration section of network card).

share|improve this answer

edited:

I solve it here.

Just delete the bridge connection ( between your real NIC and your virtual vEthernt (of Hyper-v)) Share internet connection like in the link below and it will work. http://superuser.com/questions/489746/ubuntu-not-connecting-to-network-in-hyper-v

share|improve this answer
    
While this link may answer the question, it is better to include the essential parts of the answer here and provide the link for reference. Link-only answers can become invalid if the linked page changes. –  v2r Jun 21 at 16:50
1  
ok. i roll it back, and add the link. –  Tal Jun 21 at 17:00

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.