Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

enter image description here

Trying to update via terminal via aptitude or apt-get is not working. There is no other package management program running in the background or any other user.

I tried both, sudo aptitude update and sudo apt-get update just in case. Same problem.

Trying to do it via Update manager throws this output:

W:Failed to fetch http://archive.ubuntu.com/ubuntu/dists/precise/Release.gpg Something wicked happened resolving 'archive.ubuntu.com:http' (-5 - No address associated with hostname)

Internet connection is working since I could create this question.

Tried to do: a sudo rm /var/lib/apt/lists/* -fr but it only helped in executing both apt-get and aptitude to see them fail again at the end with the same problem.

What else could be locking the list?

share|improve this question
add comment

1 Answer

up vote 0 down vote accepted

The solution for me is a weird one.

I first cleared out the apt list, to make sure.

Then proceeded to check if there was a program locking it (Even though there was nothing in memory that suggest it so): lsof|grep dpkg/lock

Then lastly I checked to see if there was the lock file in the apt list. Nothing.

I remembered yesterday we had changed ISP (We have 2 ISP connections). So just for "going back to origins" sake and changed the ISP back.

Everything works as it should. aptitude, update manager, synaptic, software center and apt-get. But then a new question: Why did changing the ISP create this problem.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.