Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

This error message pops up when opening a document in LibreOffice:

LibreOffice 3.5
Read-Error.
An unknown error has occurred.

I can, however, open a fresh new document. This is obviously not desirable behaviour.

EDIT: I tried opening a Calc doc which I used in my 11.04 installation (which is now 12.04). The documents are as they always were, in my Documents folder. Impress files seem to open fine. I've not yet tried a Writer file yet, as I don't use them too often.

What is the problem?

share|improve this question
    
It is good practise to copy error messages in text, so they can be found using a search engine. Especially with these short messages that shouldn't be a problem to type them. Also you may get better response if you give more details about what documents you are trying to open, or from what location. –  jippie May 11 '12 at 10:24
    
Sorry about that. I've added more info. –  Gonzoza May 11 '12 at 10:32
1  
Often, you receive more (and thus "better") error messages if you try to open a document from the command line using a terminal. Could you open a terminal, cd in your Documents folder and start LibreOffice from there using libreoffice3.5 --writer <YourDocName>? –  tohuwawohu May 11 '12 at 11:22
add comment

2 Answers

up vote 2 down vote accepted

Run this command and your problem should be solved:

sudo apt-get install libreoffice

Bug reports to back this up can be found here, here, and here.

share|improve this answer
add comment

I have the same problem. Run command as it explained above and i got this error message:

krator@laptop:~/Documents$ libreoffice --writer myFile.odt 
[Java framework] Error in function createSettingsDocument (elements.cxx).
javaldx failed! 
Warning: failed to read path from javaldx
terminate called after throwing an instance of 'com::sun::star::uno::RuntimeException'
krator@laptop:~/Documents$

Any fix for this issue?


Ok, I found the answer to this issue. Here is solution:

Fixing Java Framework Error

You may get the following error when you try to run OpenOffice.

[Java framework] Error in function createSettingsDocument (elements.cxx).
javaldx failed!

If so, give yourself ownership of ~/.config/ like so:

sudo chown -vR username:users ~/.config
share|improve this answer
    
Thanks for the answer. This fixed my problem. –  Jistanidiot Jan 8 '13 at 22:36
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.