Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

A month or so ago I updated from 10.04 to 10.10, the problem is that after the update process programs that I had full control of no longer respond to me as a regular user, and work normally only when I run them through the terminal using sudo.

Any idea how to fix that? The programs that don't run normally are all the programs I installed before the distribution upgrade.

I used sudo update-manager -d to upgrade btw.

share|improve this question
    
How and where did you install these programs? Did you install using a *.deb or did you compile from source? –  Takkat Nov 16 '10 at 20:11
    
We need to know the name of the programs, the user and group they execute under, if you had to reinstall them and what they do (communicate the hardware?) –  Martin Owens -doctormo- Nov 16 '10 at 23:46
    
all the programms i intalled were from the ubuntu software center except mysql that i used the alterantive installer for, and the user premmision for them is seems to be set to root,is there anyway to order the command line to reinstall all the programs? i'm pretty sure it will fix them,my theory is that the premmisions were set to root for all the programs that i had before the update –  david25 Nov 18 '10 at 0:11

1 Answer 1

up vote 1 down vote accepted

Can you reproduce this symptom with a fresh, new user account?

share|improve this answer
    
i tried with no succcess ,i opend a new user and it seems to work allright, oh and by the way since i wrote the question another thing started to happen when i log into my user i get a error regarding the fact ubuntu cannot authenticate my password –  david25 Nov 26 '10 at 23:12
    
It looks like this is an upgrade-specific issue, then. Have you tried resetting the permissions for one specific application's settings in your home directory? –  Daniel T Chen Nov 27 '10 at 2:41
    
sorry for the ignorance, since i'm quite new to Linux but how do i reset the premisions for a specific application? –  david25 Nov 27 '10 at 16:27
    
well i got over the problem,sort off-i just formated and reinstalled. –  david25 Nov 28 '10 at 13:03

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.