Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

This Ubuntu 12.04 box happens to freeze all of a sudden under regular usage - anything seems to be able to make it freeze. In one effort of seeing what could fix it, I've disabled KMS (Kernel ModeSetting), as recommended here.

In my case, it is:

echo options nouveau modeset=0 > /etc/modprobe.d/nouveau-kms.conf

Since this is an NVIDIA GeForce2 Integrated (on-board) card on an old motherboard (A7N266-VM).

And after it restarts, the only resolution avaliable is 640x480, while before, it could do 1024x768.

I want to know if disabling KMS fixes my problem, so:

How can I have the correct (1024x768) resolution with KMS disabled?

share|improve this question

1 Answer 1

I've come with an answer this time. But I've also got a question in case somebody wants to help me out too.

Okay, so here's the answer for my problem, I don't know if this will work for you, but you can (and probably have already) try. Reboot and go into recovery mode. Choose to run failsafe graphics mode. Choose what I believe is the second option, it's something like "restore default graphics". Do this and then reboot.

To answer your question (in a previous comment), it happened all of a sudden. I've got it mostly fixed now. Ubuntu is back to normal resolution, but once I log in as user, it still registers that my settings want 640x480 and the resolution changes. But I can't go into Displays and change my settings, because the save button is cut off at the bottom of the screen and I can't press it. The window size seems impossible to change. Got any ideas of how to fix that?

Edit: I fixed this (accidentally) by pressing Fn+F8, which is the command to change displays on my machine.

share|improve this answer
    
My best guess is that you should look at editing xorg.conf through the console, which probably doesn't exist so you'd have to X -configure or something. But in any case, you'd be better off asking it as a separate question, not because I'm bothered, but because it has higher chances of people seeing it and responding. In my case, I can have the correct resolution by not disabling KMS. By the way, try re-installing Ubuntu. If your /home partition is separate from your / partition (it should, it's easy to do), it will be easy to re-install, and all your settings will be there, everything. –  Camilo Martin May 13 '12 at 13:01
    
See my newest edit for how I ended up fixing this. I don't really understand how that helped, but it was nicer than reinstalling. Thanks though, Camilo, for your input! –  TandemBikeTerry May 13 '12 at 15:16
    
I'm glad you solved it :) –  Camilo Martin May 14 '12 at 10:19

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.