Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

Using VMWare Player 4.0.3 on Windows 7 64bit, with Ubuntu 12.04 as my guest OS.

I installed open-vm-tools, based on the instructions at https://help.ubuntu.com/community/VMware/Tools. I had to create the hgfs directory

sudo mkdir /mnt/hgfs

so that Shared Folders would work, and they did, at least until I rebooted the guest. If I disable the shared folders and re-enable, then they work again, until I reboot the guest.

How can I get VMware Shared Folders to persist past a reboot?

share|improve this question

closed as off topic by belacq, Jjed, fossfreedom May 18 '12 at 20:02

Questions on Ask Ubuntu are expected to relate to Ubuntu within the scope defined by the community. Consider editing the question or leaving comments for improvement if you believe the question can be reworded to fit within the scope. Read more about reopening questions here.If this question can be reworded to fit the rules in the help center, please edit the question.

1 Answer 1

VMware Player should give you an option to set Shared Folders to Always Enabled instead of Enabled until next power-off or suspend (which is the problem you seem to have). If you don't see such an option, just add this line to the .vmx file for your Virtual Machine:

isolation.tools.hgfs.disable = "FALSE"

If that line already exists, set it to "FALSE".


The VMX file contains the configuration for a virtual machine. If you don't know where that is, open terminal, and type sudo updatedb; sudo locate .vmx to get the location of the VMX file you want, and then type gksudo gedit "path-to-vmx-file.vmx".


Alternately, instead of open-vm-tools, try the latest official VMware Tools for Linux guests on VMWare player, available here and here.

Note that VMWare Tools now include an experimental feature to automatically rebuild modules when a new/different kernel is detected:

!!! [EXPERIMENTAL] !!!
VMware automatic kernel modules enables automatic building and installation of
VMware kernel modules at boot they are not already present.  By selecting yes,
you will be enabling this experimental feature.  You can always disable this
feature by re-running vmware-config-tools.pl.

Would you like to enable VMware automatic kernel modules?
share|improve this answer
    
Inside VMware Player, VM Settings > Options > Shared Folders is set to "Aways Enabled". Inside .vmx, isolation.tools.hgfs.disable = "FALSE". I think the issue is with the open-vm-tools package and how it handles hgfs at boot. –  pcapademic May 11 '12 at 19:21
    
Instead of open-vm-tools, if the bundle included in there is older than 8.8.2, try the official packages from VMware: - softwareupdate.vmware.com/cds/vmw-desktop/player/4.0.3/703057/… - softwareupdate.vmware.com/cds/vmw-desktop/player/4.0.3/703057/… and compile with vmware-config-tools.pl –  izx May 12 '12 at 5:13
    
Using the traditional VMWare Tools package defeats the purpose of trying open-vm-tools. Furthermore, I am hoping that using open-vm-tools will reduce the number of times I find stuff not working, until I spend half a day remembering that I need to recompile vmware tools against the new kernel. So, it's an experiment. –  pcapademic May 12 '12 at 15:32
    
See edits to answer. Suggest you file a bug report with open-vm-tools maintainers. Good luck with your experiment! –  izx May 13 '12 at 3:56

Not the answer you're looking for? Browse other questions tagged or ask your own question.