Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I have a desktop PC which I built a while back. It has an Athlon XP 2500+, 2.5GB RAM, and an Nvidia (PNY Verto) Geforce 6200. I removed the CD drive to add another hard drive so I install from a USB flash drive.

When I try to install 12.04 it seems to work just fine. The GUI boots up and wifi even connects to my router. I go through the language screen, the partition screen, the keyboard screen, the location screen, and the import my Windows settings screen just fine.

But as soon as I'm done with all that the next screen goes black and displays this message:

drm:[drm_crtc_helper_set_config] *ERROR* failed to set mode on [CRTC6]

Since the GUI starts just fine earlier during the install, I know I shouldn't be having any display problems, but I am. How do I get Ubuntu to install properly?

I have four IDE hard drives, all Western Digital: a 250GB, a 160GB, a 40GB occupied by Windows XP, and a 120GB that I'm trying to use for Ubuntu. 3GB of the 120GB drive are formatted for swap.

I have checked the MD5sum of install image file and it all matches up.

d791352694374f1c478779f7f4447a3f ubuntu-12.04-desktop-i386.iso
share|improve this question

1 Answer 1

This is a long shot, but it might be worth trying just to conclusively rule it out.

Have you tried adding the kernel option/parameter nomodeset when you boot your install media?

If you need more detail on how to do this try looking at this answer to another question.

BTW, you are not using multiple monitors, are you? If so, then perhaps try disconnecting all but one of them during the install? (He's been there, done that. No joy.)

Perhaps try the Alternate Install?

I'm not sure if this is a "good" suggestion but, like nomodeset, it might be worth at least trying.

The description of the Alternate Install media on the Ubuntu community wiki says:

It may happen occasionally that your computer is not able to run the standard Desktop installation CD because it does not meet the hardware requirements, or the required drivers are missing from the standard LiveCD. ... The Alternate CD allows more advanced installation options which are not available with the Standard LiveCD.

The Alternate install ISO does a text mode install.

If you decide to try it you can obtain the Alternate install ISO from the Ubuntu 12.04 LTS releases page.

share|improve this answer
    
Yes,I am using dual monitors,plus a TV via S-Video my card has a DVI plug,a VGA plug,and an S-Video plug.The monitor plugged into the DVI plug is plugged in with a DVI-VGA adapter.Tried with each monitors separately,S-Video disconnected,and on the DVI,with both the monitor and adapter disconnected.When the only monitor plugged in is in the DVI adapter,Get the same error when the monitor is plugged in to the VGA plug,I didn't see an error,but the install did basically the same thing. On both,or with dual monitors, the mouse pointer with the loading icon is still on the screen and can be moved. –  Warez J. Coxtrong May 11 '12 at 2:35
    
The install doesn't give me the popup with options when I hit F6, so I edited the parameters this time and put --nomodeset at the end. Guess I'll know more in a few minutes. –  Warez J. Coxtrong May 11 '12 at 2:42
    
OK, when the only monitor plugged in is in the VGA port, I don't get an error message. Right after the "import windows settings" screen, the dialog box goes away, shows the wallpaper and top bar for a couple seconds, then the screen goes black. I switched terminals, ran dmesg, and I get this on the last line- init: lightdm main process (10949) terminated with status 1 Before that it's just messages regarding the filesystem, which I'm pretty sure just have to do with creating/preparing partitions from when the GUI was still up. –  Warez J. Coxtrong May 11 '12 at 2:55
    
I edited my answer but I don't think you are notified unless I add a comment. –  irrational John May 11 '12 at 3:01
    
ah ok. I'll try that if this doesn't work. I put the nomodeset directly after splash, before the -- and it seems to be doing something different now. the loading screen said Ubuntu 12.04 instead of just the Ubuntu logo, and seemed to be at a lower resolution. I've got a black box surrounding the screen now, so I'm thinking definitely at a lower resolution. I'm going to run through this real fast and see if it works. –  Warez J. Coxtrong May 11 '12 at 3:06

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.