Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I am using ubuntu 12.04 with unity 2d. I want to change the wallpaper per workspace, i came across few gconf editor related tutorials but is it possible in any other way? Does unity have it built in or I will have to hack it from these tutorials?

I want it to work on both unity2d and Unity3d.

share|improve this question
1  
For 11.10 and below: askubuntu.com/questions/75998/… –  desgua May 11 '12 at 0:52
    
To add on to the previous comment, it seems that compiz will be needed to accomplish this. –  ruffEdgz May 11 '12 at 18:16
    
I originally did this approach in 11.10 and after upgrading to 12.04 it continued to work. –  NikolaiDante May 21 '12 at 9:04
add comment

1 Answer

  1. Install Compiz Settings Manager:

    sudo apt-get install compizconfig-settings-manager

  2. Press Atl + F2 and run:

    gconf-editor

  3. Navigate to apps > nautilus > preferences and uncheck show_dekstop.

  4. Next, open the Compiz Setting Manager and go to the Wallpaper plugin.

  5. Click “New” to choose a wallpaper for your first workspace.

  6. Browse to select an image.

  7. Repeat the steps for all your workspaces. Once done, enable the wallpaper plugin.

  8. Unity’s theme will look weird after enabling the plugin. Restarting the computer will fix it.

Source: http://joesteiger.com/2011/07/18/enable-different-wallpapers-for-each-workspace-in-unity-ubuntu-11-04/

Hope this helps,

Leinardo

share|improve this answer
2  
Having problems with following steps in Ubuntu 12.04. 1>gconf-editor doesnt have an option of show desktop in preferences in nautilus. 2> In compiz cant get any wallpaper plugin Any suggestions? –  Srijan Jun 25 '12 at 23:30
2  
In 12.04, there is no "show_desktop" in apps > nautilus unfortunately. –  Benjamin Jun 27 '12 at 9:55
    
In later versions this option is available via (Gnome) Tweak Tool under "Desktop > Have file manager handle the desktop". –  artm Mar 18 '13 at 8:05
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.