Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I've recently installed Ubuntu 12.04 via wubi, and have so far been unsuccessful in configuring the system to allow a 1366x768 screen resolution. The platform is an HP Pavilion g6-1d73us with Intel HD Graphics 3000, and in Windows 7 the highest resolution is 1366x768.

Please let me know what specific information is needed to diagnose this problem, and I will be happy to report back here.

share|improve this question
    
Update from lshw -C video: *-display UNCLAIMED description: VGA compatible controller product: 2nd Generation Core Processor Family Integrated Graphics Controller vendor: Intel Corporation physical id: 2 bus info: pci@0000:00:02.0 version: 09 width: 64 bits clock: 33MHz capabilities: msi pm vga_controller bus_master cap_list configuration: latency=0 resources: memory:c0000000-c03fffff memory:b0000000-bfffffff ioport:5000(size=64) Sorry for the horrible formatting, but I can't seem to make Markdown work :( –  Matthew May 12 '12 at 19:14
    
Update: I ran a test using a Linux Mint 12 live CD to see if the desired resolution would show up in an earlier version of Ubuntu (Linux Mint 12 has 11.10 as its base). Sure enough - 1366x768 works in Linux Mint 12. I then dropped wubi 12.04 and installed wubi 11.10 - 1366x768 works there too. –  Matthew May 12 '12 at 22:07
    
Final update: it appears that 12.04 is good to go. I had added "nomodeset" to the boot options in response to the fact that the screen would go blank after the splash. All is good now. –  Matthew May 14 '12 at 2:22

2 Answers 2

What have you tried so far?

Usually, you just navigate to 'Displays' in 'System Settings' and change the resolution.

enter image description here

If that does not show you the resolutions you want, you may need to install the appropriate driver for your video card. Again, got to 'System Settings' and open 'Additional Drivers' and see if there's any video driver available:

enter image description here

If there is any video-related driver available (mine is just an example), activate it and restart. Now 'Displays' screen may show more resolutions.

share|improve this answer
    
I have gotten that far :). It is in that dialog that I see a max resolution of 1024x768. I have not gone any farther than that. –  Matthew May 11 '12 at 21:33
    
@Matthew: updated the answer with more troubleshoot options. –  MestreLion May 11 '12 at 22:21
    
first of all, thank you for taking the time to make screenshots with numbered steps. Way to go above and beyond!! I followed your steps, and I do not appear to have any additional drivers available for my system (in any category). –  Matthew May 12 '12 at 1:54
    
@Matthew: Thank you for the compliments. Feel free to upvote the answer if you appreciate the effort so far. But don't mark it as the accepted answer until we find a solution for your issue. –  MestreLion May 12 '12 at 2:03
    
I sort of fixed the problem - or at least identified that the problem is 12.04 (I don't see the problem in 11.10). –  Matthew May 12 '12 at 22:08

have you tried to "add" the resolution?

I did this with an HP 1740 monitor.

You could use a .sh file to add that, lets say for example, you want to add a 1280x1024 resolution:

fixme.sh:

#!/bin/sh
xrandr --newmode 1280x1024_60.00  109.00  1280 1368 1496 1712  1024 1027 1034 1063 -hsync +vsync
xrandr --addmode VGA1 1280x1024_60.00
xrandr --output VGA1 --mode 1280x1024_60.00

Then you can execute your file:

sh fixme.sh

and there you go, new resolution available

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.