Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

*Problem solved *

I had to enter the Options menu in Keyboard layout settings. Then choose "Key(s) to change layout", and check the "Right alt" alternative.

But thanks anyway for all the great answers/comments to this question! :-)

When I installed Ubuntu 12.04, curly brackets no longer worked. I then reinstalled 12.04, and everything worked fine until I hooked my laptop up with my Apple wireless keyboard. I then found out that all the keybindings with alt/meta was gone.

This is the output from xev when AltGr + 7 is pressed:

KeyPress event, serial 35, synthetic NO, window 0x3200001,
    root 0xc4, subw 0x0, time 73403321, (208,74), root:(1114,151),
    state 0x0, keycode 108 (keysym 0xffea, Alt_R), same_screen YES,
    XLookupString gives 0 bytes: 
    XmbLookupString gives 0 bytes: 
    XFilterEvent returns: False

KeyPress event, serial 35, synthetic NO, window 0x3200001,
    root 0xc4, subw 0x0, time 73403396, (208,74), root:(1114,151),
    state 0x8, keycode 16 (keysym 0x37, 7), same_screen YES,
    XLookupString gives 1 bytes: (37) "7"
    XmbLookupString gives 1 bytes: (37) "7"
    XFilterEvent returns: False

KeyRelease event, serial 35, synthetic NO, window 0x3200001,
    root 0xc4, subw 0x0, time 73403471, (208,74), root:(1114,151),
    state 0x8, keycode 108 (keysym 0xffea, Alt_R), same_screen YES,
    XLookupString gives 0 bytes: 
    XFilterEvent returns: False

KeyRelease event, serial 35, synthetic NO, window 0x3200001,
    root 0xc4, subw 0x0, time 73403484, (208,74), root:(1114,151),
    state 0x0, keycode 16 (keysym 0x37, 7), same_screen YES,
    XLookupString gives 1 bytes: (37) "7"
    XFilterEvent returns: False

Anyone know what to do?

I have disabled the function where the alt-key shows the HUD in Unity. Things I have tried:

  • The lsusb did not show me any keyboard. I use the Apple wireless keyboard, with Norwegian (Macintosh) keyboard layout. All the keys are recognized so It seems like its just the combination that dont work anymore. The same happened with alt+tab, but I just had to change some things in the compiz-settings.

  • I also tried the onscreen keyboard, and pressed AltGr + shift, that made it possible for me to use brackets++.

share|improve this question
    
What it your keyboard layout? What happens when you press the curly bracket key (or key combination)? Are the curly brackets the only affected characters? –  Gilles May 10 '12 at 22:06
    
My keyboard layout is Norwegian (Macintosh), when i press alt/alt gr + 7/8/9/0 nothing happens. So far, I havent noticed anything else but the curly brackets, but It's kind of a problem since I'm doing programming on my computer :p –  chhristian May 11 '12 at 10:07
    
The following information may help find out where the problem is: Open a terminal and run the program xev. It will display debugging information about input events. In the xev window, press AltGr, press 7, then release both keys. Copy-paste the xev output for this into your question. If there is another AltGr combination that works, also copy-paste the output for that combination for comparison. –  Gilles May 11 '12 at 10:47
1  
KeyRelease event, serial 35, synthetic NO, window 0x3200001, root 0xc4, subw 0x0, time 66236014, (-106,-28), root:(459,0), state 0x8, keycode 16 (keysym 0x37, 7), same_screen YES, XLookupString gives 1 bytes: (37) "7" XFilterEvent returns: False –  chhristian May 11 '12 at 16:10
    
This shows you releasing the 7 key. Can you add the previous two KeyPress chunks as well? The most interesting one is you pressing the AltGr key. And please edit your question (use the edit button below the question text and the tags, above the comments). –  Gilles May 11 '12 at 18:05

1 Answer 1

As I can not comment, I have to put this ideas into the answer field:

Could you please post more Information about the laptop (brand, model).

If you are on a Laptop and the keyboard is probably internally attached via usb. So you might want to check the command lsusb (in terminal) to confirm that it is detected correctly.

(My lsusb output with keyboard marked in yellow) My keyboard in lsusb

You might want to take a look into your system settings keyboard tab. enter image description here

In the typing tab on the bottom there shoud be a link to get you in the layout setting. enter image description here Here you can play around with some of the options and see if it helps. If you click on your keyboard layout in the list (Probably labeled English in my case it is German) and the keyboard symbol on the bottom of the list (5th symbol) enter image description here you can see your current keyboard layout visually to see if everything looks fine there. enter image description here You can press keys in this view and see If they are recognised. This is important to check if your alt-gr key is correctly mapped to the alt-fn combination you probably use

share|improve this answer
    
The lsusb did not show me any keyboard. I use the Apple wireless keyboard, with Norwegian (Macintosh) keyboard layout. All the keys are recognized so It seems like its just the combination that dont work anymore. The same happened with alt+tab, but I just had to change some things in the compiz-settings. –  chhristian May 11 '12 at 7:21
    
The laptop model is: Toshiba Satellite A500D-111. –  chhristian May 11 '12 at 10:09

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.