Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I'm maintaining an application on Ubuntu 8.04. The application has a facility to change the language and then reboot. When it reboots a dialog box is presented that asks if I want to change the filenames to the new language.

I don't want to do so. I never even want to see that box. How can I do this?

More info: The application changes the language by

  1. rewriting /etc/default/locale
  2. calling setlocale()
  3. rebooting

The system is configured so that the user never sees ubuntu. The system is set to autologin a particular user and that user's gnome configuration files start the (full screen) application.

The prompt to change filenames is displayed before the user is auto-logged in and only displays for a few seconds. I would not like it to be displayed at all.

Does anyone know where this happens in the boot process and how I can disable it?

share|improve this question

1 Answer 1

The prompt to change filenames is provided by the program xdg-user-dirs-gtk-update which runs very early in the GnomeDisplayManager login process.

This program looks at the file /etc/xdg/user-dirs.conf for some options. It can be disabled by a flag in that file.

It can also be disabled on a per-user basis by creating/editing a similar file in the users .config directory.

More information can be found at http://www.freedesktop.org/wiki/Software/xdg-user-dirs, though the file names used there might be confusing at first glance.

Please note that the directories containin these configuration files may be somewhere else. Refer to the web page for more information

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.