Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I have a Dell Studio 1555 with ATI Radeon HD 4570 card in it.

Upon running Unity Support Test, it says Unity 3D is not supported.

shantanu@GreenHead:~$ /usr/lib/nux/unity_support_test -p
OpenGL vendor string:   ATI Technologies Inc.
OpenGL renderer string: ATI Mobility Radeon HD 4500 Series
OpenGL version string:  1.4 (2.1 (3.3.11627 Compatibility Profile Context))

Not software rendered:    yes
Not blacklisted:          yes
GLX fbconfig:             yes
GLX texture from pixmap:  yes
GL npot or rect textures: yes
GL vertex program:        yes
GL fragment program:      yes
GL vertex buffer object:  no
GL framebuffer object:    yes
GL version is 1.4+:       yes

Unity 3D supported:       no

Does this mean that 3D will not work at all or it requires some additional drivers, etc.? I tried installing flgrx using apt-get as well as using Additional Drivers from the menu, but neither helped.

How can I get 3D working on this card?

EDIT: Someone on ubuntuforums had similar issue and got it resolved, but cannot make out what exactly did he do to solve it.

share|improve this question
    
Did you install ATI drivers from additional drivers? –  izx May 10 '12 at 22:01
    
Yes I did that. –  Ravi S Ghosh May 11 '12 at 5:52
    
I installed ATI driver for my HD4200 card from AMD website, see how to install this driver in this answer. –  Boris Sep 21 '13 at 6:56

2 Answers 2

I've a radeon HD3450 and worked until shortly with the fglrx driver. Unity functioned than in 3D. The only think I did is select the additional driver as Ubuntu pointed out in additional drivers, reboot and it functioned. I think your card is quit similar. So look if Ubuntu shows fglrx with additional drivers.

I've some warnings for you: 1. with the fglrx-driver the system is not always stable (at least with my card). When switching you 'll see shortly all kinds of strange graphics and some times the system hangs. Some applications did not function right with this driver. Like the xscreensaver (it does not show a unlock box) or it hangs sometimes when shutting down the system. 2. The radeon driver is sometimes instable when it boots early (look on the internet with keywords: flash or flicker and "radeon.modeset=0"). It is common that most os drivers boot early when the kernel loads. On my system the radeon driver makes it slow and all the time I have flashes with the driver early loaded. To make the driver start late and function right you will have to add the option: radeon.modeset=0 in grub, you can add this command in the file: /etc/default/grub just behind "quiet splash" the line will be: GRUB_CMDLINE_LINUX_DEFAULT="quiet splash radeon.modeset=0" 3. AMD did drop the support for our graphics cards. So from Ubuntu 12.10 and later it is not supported.

I switched back to the radeon driver and use unity-2D (so what? it works). Some 3D functionality functions tough (I think/heard) only not with opengl/Unity. I read on internet tough that it is possible to get it working in 3D (and fast and stable) when you install Ubuntu 12.10 and ad a 3.6 kernel (not standard). See:

http://www.ubuntuvibes.com/2012/10/how-to-enable-opengl-30-support-for.html

I like the Long time support of Ubuntu 12.4 and will stick with Unity-2D (games functions, my video's run fast enough, etc.).

Good luck.

share|improve this answer

Some users reported for the Radeon HD4xxx series to have also installed (apart from the Proprietary drivers) the xserver-xorg-video-ati package. So do this:

sudo apt-get install xserver-xorg-video-ati

unity_support_test should now show you YES on the Unity 3D Support.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.