Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

After I upgraded to 12.04, my second monitor is detected (in display settings), but will not power on.

I have scoured the Internet and forums for a solution and I can't find anything. I have found a couple people with the same problem, but never a solution for it.

I am no expert, but I'm certainly not a noob.

My computer uses AMD Radeon 6250 graphics, but I do NOT want to use the proprietary graphics drivers. They refuse to work properly with my second monitor (they ATI drivers will only mirror screens, and I've done everything to try to fix it, and I DON't want mirrored screens) Not to mention that the default open-source video drivers seem to work much better than the proprietary anyway!

Again, Ubuntu's default video drivers work fine, and they even DETECT the second monitor (Dell 19'). I can drag stuff off the screen and put it on the 'space' of the second monitor and even a screen-shot shows that there are two monitors active; but the monitor is OFF. It will not power on. It goes into 'power-save' mode because it is not receiving a signal.

For some reason it is not getting the signal to power on, even though Ubuntu thinks the monitor is working properly.

I had this working fine on my Sony VAIO yesterday (with Radeon graphics/default Ubuntu video drivers). I upgraded to a Samsung Series 3 and now I have this issue.

I can't for the life of me figure out why the monitor is connected, detected and I have screen space for the monitor, but the screen won't turn on!


XRANDR Output:

Screen 0: minimum 320 x 200, current 1366 x 768, maximum 8192 x 8192

VGA-0 connected (normal left inverted right x axis y axis)
   1440x900       59.9 +   75.0  
   1280x1024      75.0     60.0  
   1152x864       75.0  
   1024x768       75.1     70.1     60.0  
   832x624        74.6  
   800x600        72.2     75.0     60.3     56.2  
   640x480        72.8     75.0     66.7     60.0  
   720x400        70.1  

LVDS connected 1366x768+0+0 (normal left inverted right x axis y axis) 344mm x 194mm

   1366x768       60.1*+
   1280x720       59.9  
   1152x768       59.8  
   1024x768       59.9  
   800x600        59.9  
   848x480        59.7  
   720x480        59.7  
   640x480        59.4  
HDMI-0 disconnected (normal left inverted right x axis y axis)
share|improve this question
    
can you post the output of xrandr please? –  Jelle Smedts May 10 '12 at 20:17
    
@user62458 please edit your question as add them, not as comments –  Sathya May 11 '12 at 7:57
    
@sathya my apologies. I have reformatted the comments as you suggested. Can you offer any help, in addition to your critique? –  user62458 May 11 '12 at 18:02
    
I'm sorry for posting this in answer form, i can't for the life of me find the comment button (i'm on a small screen with a pretty old firefox so it may simply not work here?) Anyway i have the exact same problem with an nvidia 8600 gts in ubuntu 12.04 with the proprietary driver enabled. Second screen is "functional" as far as ubuntu is concerned but doesn't show anything. Perhaps it is a general dual monitor issue instead of ati/nvidia specific? Note that this particular hardware setup has been working for +-4 years with ubuntu but is broken in 12.04 –  user62683 May 11 '12 at 18:03
    
@user62458 I've formatted the edit, it will needs to be approved. Unfortunately I don't know much on this, so I can't help more than beautifying the post. –  Sathya May 11 '12 at 18:07

1 Answer 1

First of, I'm using Ubuntu 12.04, too with the newest nvidia drivers.

I have had the same problem but came up with a (for me) suitable solution. From various other posts I did these steps to get my dual-monitor setup running (this might not be the smartest or best solution but it worked for me):

I opened a terminal, entered

gksu nautilus

and moved to "/etc/X11/xorg.conf" to delete the config file.

I closed the terminal, reopened another one and used

sudo nvidia-settings

to save the following files correctly.

Now, the only way I could find to enable both monitors was to select TwinView and arrange the monitors as i wanted them to. Seperate X screen didnt work at all.

I clicked "Save to X Configuration File" and entered

/etc/X11/xorg.conf

because the path was missing (if you deleted the file somewhere else enter that path).

Restart the computer. When I did this it now only displays some error message but at least my displays are useable. What I don't like is having the "start bar" or whatever it is called on both screens, I haven't found a solution to disable it on my secondary screen. But I can live with that I guess...

I hope that helped you.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.