Ask Ubuntu is a question and answer site for Ubuntu users and developers. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I'm trying to send an email using mutt like this:

echo 1.txt | mutt -s Hello -a file.tar.bz2

It's getting no error, but I didn't receive the email. What's the problem?

share|improve this question
up vote 4 down vote accepted

Assuming that you are using a local smtp server, have you checked the maillog? If that is the case, please post some of the log...

share|improve this answer
I'll be thankful if you tell me where can I find the log. – Sina May 10 '12 at 19:14
There are 2 logs that could be relevant: /var/log/mail.log and /var/log/mail.err It sounds thought that you don't have a mail server setup on your machine, did you configure mutt for a Gmail account? – Mordoc May 10 '12 at 20:47
If you haven't set Mutt up for Gmail use, here's a great guide on the setup required:… – Mordoc May 10 '12 at 20:51
It worked, thanks :D – Sina May 10 '12 at 21:09

Try launching mutt with debug level 1 with the command: mutt -d 1

I solved my problem this way (the certificate couldn't be saved, and mutt was silently not sending emails).

share|improve this answer

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.