Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I have Windows 7 and Ubuntu 12.04 in my system and i saw that the default time for os selection menu is only 10 sec, as i am new to Linux can anyone tell me how to increase this time?

share|improve this question
add comment

6 Answers

  • Press Alt + F2

  • Type command, gksu gedit /etc/default/grub

  • change the GRUB_TIMEOUT value to 15 or 20 as required. (value in second) or Setting timeout to -1 will make GRUB wait indefinitely until you manually select an entry and hit enter, It should look like

    GRUB_TIMEOUT=10

  • save it. Close gedit. Now open a terminal and run

    sudo update-grub

share|improve this answer
add comment

I used to use startup manager, as pointed out by Chad--24216, but alas, it's no longer being maintained, nor is it in the repositories.

It has been superseded by "grub-customizer", which while up to date, is also not in the standard repositories. To to add and install it simply do the following at the terminal:

sudo add-apt-repository ppa:danielrichter2007/grub-customizer

Press enter to confirm adding the PPA

sudo apt-get update
sudo apt-get install grub-customizer

Press Y to confirm

You can now launch grub-customizer in the usual ways. If you ignore the complete list you'll see when it first launches, and just press "Preferences" button on the toolbar you'll get a nice summary dialog where you can change the timeout value and default menu item, as shown below:

Grub Customizer preferences screen

Sources:

Startup Manager is dead

Grub Customizer PPA

share|improve this answer
    
Its a Correct answer and Useful too! Thank U! –  Gaurav Sep 13 '12 at 8:52
add comment

You need to edit /etc/default/grub file by opening a terminal and running this command: sudo gedit /etc/default/grub

You need to set the value of GRUB_TIMEOUT to how long (in seconds) you want the grub menu to appear. GRUB_TIMEOUT is actually the number of seconds before the default entry is automatically booted. If you want to see the menu for 10 seconds which is the default, then do:

GRUB_TIMEOUT=10

Also, make sure that you add # before the GRUB_HIDDEN_TIMEOUT=0 line:

#GRUB_HIDDEN_TIMEOUT=0

Then do a sudo update-grub and reboot.

share|improve this answer
add comment

There are two ways to do it

  1. Start-up Manager (Development discontinues)
  2. Grub customiser (Not in the official repositories as yet)

Using Start-up manager (available upto 12.04)

Install it by typing:

sudo apt-get update
sudo apt-get install startupmanager
  1. Open up start-up manager

  2. Change the timeout setting to 10 secs

    enter image description here


Using Grub Customiser

  1. To to add and install it simply do the following at the terminal (You need to add a PPA):

    sudo add-apt-repository ppa:danielrichter2007/grub-customizer

    Press enter, then type

    sudo apt-get update
    sudo apt-get install grub-customizer

    And press Y to confirm

    Grub Customizer preferences screen

  2. Click on the General tab and change the time out to 10 secs


Hope that helps.

share|improve this answer
1  
Is startup manager installed by default?. Also I heard, that project is dead now. –  Anwar Shah Jul 15 '12 at 14:43
    
@AnwarShah the op hasnt specified his OS version... the older OS has startup manager, doesnt it? –  Ashu Jul 15 '12 at 14:48
    
In that case, you can clarify the OP. Also, I don't think startup manager was included in the previous releases –  Anwar Shah Jul 15 '12 at 14:49
    
@AnwarShah i'll include the option for newer versions of ubuntu also. –  Ashu Jul 15 '12 at 15:05
    
@AnwarShah edited my answer.. see if it fits what you wanted. –  Ashu Jul 15 '12 at 15:20
show 3 more comments

Web-E's answer is really the best way to do it. However, if you want a GUI way of modifying GRUB that doesn't involve editing a file, you can download an install "startupmanager" from USC or Synaptic. Or with Universe repo enabled, you can open Terminal and install by typing:

sudo apt-get update
sudo apt-get install startupmanager
share|improve this answer
    
startup manager package is not available in 12.04 . –  Web-E May 11 '12 at 2:04
add comment

You need to change the timeout for grub.
Have a look at this guide for really simple instructions on changing grub's timeout / os selection time :

how to change the time for os selection menu in grub

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.