Ask Ubuntu is a question and answer site for Ubuntu users and developers. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

This question already has an answer here:

How do I setup proxy exceptions under Ubuntu 12.04?

Already tried the proposed solutions for earlier Ubuntu versions and none seem to work. There is no Network Proxy Preferences in 12.04 AFAIK.

System Settings -> Network -> Network Proxy does not offer the possibility to add exceptions.

Is there a file where these settings reside so I can edit them manually and add exceptions (and so the settings are honored by all network apps)?

I would really appreciate any info on this one not already mentioned on earlier answers, as none of theme worked for me. Thanks!

share|improve this question

marked as duplicate by jokerdino Jun 3 at 7:29

This question has been asked before and already has an answer. If those answers do not fully address your question, please ask a new question.

I agree with Alex: the main/regular interface could be a lot better if there was a text field for the ignore list. Anyways: for those using 12.10, there is no gconf-editor. Only the dconf-editor will help. – Stefano Mar 26 '13 at 16:14

You use either gconf-editor /system/http_proxy/ignore_hosts
or dconf-editor (and manually navigate to system -> http_proxy -> ignore_hosts).

Contrary to what others wrote, there is no need to re-login for changes to take effect.
Moreover, settings done for /system/http_proxy/ignore_hosts also take effect for https.

share|improve this answer

I had the same issue with 12.04 and the solution given on this thread worked for me.

share|improve this answer

Thanks nvk, this finally worked for me too, but there is a catch:

In dconf-editor there is a help text that reads something like 'if no configuration for https is given, the proxy server configured for http will be used for https too'. This is not true, at least for Ubuntu 12.04. I had to add the server for all protocols, even being the same one for http, ftp and https. After I did this, and after a logging off and in again, proxies (including exceptions) took effect for all applications.

Still, I think the 'normal' network settings GUI could be made better by the addition of an extra input box for the proxy exceptions in the proxies settings part. I hope to see this in a future Ubuntu update.

share|improve this answer

protected by Community Mar 26 '13 at 16:45

Thank you for your interest in this question. Because it has attracted low-quality or spam answers that had to be removed, posting an answer now requires 10 reputation on this site (the association bonus does not count).

Would you like to answer one of these unanswered questions instead?

Not the answer you're looking for? Browse other questions tagged or ask your own question.