Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

iwconfig reports 11 Mbps, yet I've seen as low as <1 KBps. This is the latest in my laundry list of Ubuntu problems in a dual-boot machine (cyberpowerpc custom, intel i7-3820, nvidia gtx 570). I received it two days ago, Windows 7 running fine, still having problems with Ubuntu.

The browsing is intermittent but unacceptable. e.g. I could get to this site last night but I couldn't post this question. The downloading is unbearably slow, I can't download anything or install any packages because the speed is so slow.

e.g. I am trying to install vim which is inexplicably missing from my 12.04 install (add another one to the problems list) and my download speed reported in the terminal was 241 B/s. Yes, bytes.

iwconfig reports 11 Mbps, which further adds to the confusion.

User@ubuntu:~$ iwconfig

lo no wireless extensions.

wlan0 IEEE 802.11bgn ESSID:"linksys" 

Mode:Managed Frequency:2.437 GHz Access Point: 00:18:39:76:2C:A1

Bit Rate=11 Mb/s Tx-Power=20 dBm

Retry long limit:7 RTS thr:off Fragment thr:off Power Management:off Link Quality=36/70 

Signal level=-74 dBm

Rx invalid nwid:0 Rx invalid crypt:0 Rx invalid frag:0 Tx excessive retries:54 Invalid 

misc:18 Missed beacon:0

eth0 no wireless extensions.

Any ideas? I see this is a problem a lot of people, but none of the on line solutions have worked for me so far. e.g. one site recommends editing the ath9k.conf file in /etc/modprobe.d, yet this file isn't even in the folder:

User@ubuntu:/$ cd etc/modprobe.d 

User@ubuntu:/etc/modprobe.d$ ls 

alsa-base.conf blacklist-oss.conf blacklist-ath_pci.conf 

blacklist-rare-network.conf blacklist.conf 

blacklist-watchdog.conf blacklist-firewire.conf 

dkms.conf blacklist-framebuffer.conf nvidia-current_hybrid.conf 

blacklist-modem.conf nvidia-graphics-drivers.conf

I think the nvidia gpu might be mucking things up. I had the "blinking cursor" problem when installing in the first place, and then I had the monitor out of range problem as well. I have my faithful Asus laptop, which is running Ubuntu 12.04 just fine. The only difference is executing host -t SOA local in the terminal gives

User@ubuntu:~$ host -t SOA local 

local has SOA record local. nobody.localhost. 42 86400 43200 604800 10800

in my new machine, and the command reports Host local. not found in the laptop.

Help would be most welcome, as I am in danger of reverting back to Windows. I'm seriously considering it. Sorry for the length, trying to show my effort in resolving the issue and include terminal snippets that might be helpful.

share|improve this question
2  
Welcome to Ask Ubuntu! We need more hardware information to help you, can you look at this question and then edit your question adding the information. –  Jorge Castro May 10 '12 at 16:25
2  
We need the model # of your wireless card! –  Jorge Castro May 10 '12 at 16:25
add comment

1 Answer

I tried the ath9k.conf route, creating a new file, and it seemed to work stepping me up from 1 to 4 Mb per sec. Still only half the speed of windows with same usb stick though.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.