Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I have a gnome-shell desktop that, since the update from ubuntu 11.10 to 12.04, acts strange. In detail, I have a high CPU activity that seems (looking from other questions here) could be triggered by a theme error. Now, I have no special theme installed --- but the gnome-tweak-tool is reporting an error (look at the screenshot down here). Given that:

  • the theme list is "locked"
  • the warning signal is not clickable
  • running gnome-tweak-tool in a terminal shows no useful errors
  • activating lookingGlass shows no error whatsoever
  • .xsession-errors has not errors

Anyone knows where can I see for the specific error, or how to reset the configuration without deleting all the .dconf directory? screenshot of the "advanced settings" menu

share|improve this question
add comment

2 Answers

up vote 1 down vote accepted

LOL, that's not really an error. It just means you don't have any themes installed. It'll go away if you install some themes. Don't worry about it. :)

However, I am concerned about the high CPU activity. Have you looked at System Monitor to see what is taking up so much CPU?

share|improve this answer
    
Yes --- the process "gnome-shell" is using an average 35% CPU. That happens on my desktop box (radeon 2400) and not on my laptop (Intel graphics). –  Rmano May 16 '12 at 14:48
    
Do you have any extensions enabled? If so, try disabling them one by one and check the System Monitor each time you disable one. One of them may be causing the issue. Do the same with any programs you have starting up with Gnome Shell. –  xjonquilx May 16 '12 at 18:33
    
Triec to even un-install all the extension, nothing helps. I do not understand what you mean with "starting with gnome-shell". I start gkrellm and a log watcher, but they are different processes. The process which use 35% cpu is just "gnome-shell"... –  Rmano May 17 '12 at 21:11
    
What CPU are you using? –  xjonquilx May 18 '12 at 2:43
    
Intel Core2 VPro. Why? I can see why it could be related to the graphic driver, less with the CPU... in my netbook, much less powerful than the desktop machine, gnome-shell uses just 1-2%. –  Rmano May 18 '12 at 15:37
show 4 more comments

Found it --- it is the proprietary ATI drivers. Using the system settings, additional drivers, disabling the ATI drivers fixed CPU usage of gnome shell back where it was.

The system seems a bit slower in booting the graphic interface, but afterwards it works quite well --- note however that I do not use 3d graphics. The graphic card is an ATI Radeon HD2400 Pro.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.