Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

Recently i installed Ubuntu 12.04 on my Laptop "Dell Inspiron-N4010".

i am facing problem with my contrast control,after restarting my system contrast is getting reset to its max value.

so each time after login have to set the contrast again & again.

Please advice ....

Regards, Shiv Rajawat

share|improve this question

2 Answers 2

up vote 0 down vote accepted

I got this working on my machine, but as soon as the greeter screen appears the brightness jumps right back to maximum, any other steps I could take to find out whats causing this and override it to make the lower setting stick?

share|improve this answer

I faced the same problem on my Dell XPS. Currently there is no other way to save it according to brightness key.

  • Find your brightness control path, execute

    ls /sys/class/backlight/*/brightness
    

    the output will be something like /sys/class/backlight/acpi_video0/brightness

  • Copy that path and try executing

    sudo su -c 'echo 5 > THE_PATH_FROM_FIRST_COMMAND'
    

it will be like -> sudo su -c 'echo 5 > /sys/class/backlight/acpi_video0/brightness'

If it succed,try with different value for 5 and choose your preference level.

  • Now edit /etc/rc.local file to execute this command at boot up.

    gksu gedit /etc/rc.local
    
  • Just before exit in the file, add the following line,

    echo 5 > THE_PATH_FROM_FIRST_COMMAND
    

You can change value 5 to anything.

Linked Question:

How do I prevent Ubuntu from changing my laptop screen brightness level?

share|improve this answer
    
Let us know if it worked. –  Web-E May 10 '12 at 13:40
    
Hi Web E, as you told i run the command but i am getting two paths,please see thethakur@thethakur-Inspiron-N4010:~$ ls /sys/class/backlight/*/brightness /sys/class/backlight/dell_backlight/brightness /sys/class/backlight/intel_backlight/brightness thethakur@thethakur-Inspiron-N4010:~$ should follow the same above steps or step will be change in my case... –  The Thakur May 10 '12 at 14:33
    
any one.. I have the same problem. I use first one –  Web-E May 10 '12 at 16:03

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.