Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I have nvidia-current installed (version 295.40-0ubuntu1) and nvidia-current-updates (version 295.49-0ubuntu0.1) running on Ubuntu 12.04. These are the latest version in Ubuntu proposed, but the problem was before the update to proposed.

The problem is that after running sudo nvidia-xconfig I get a xorg.config generated as shown at the end. When I reboot the xOrg starts but in a very low resolution (failsafe mode). This happens with or without my second HDMI screen attached (which mirrors my latop screen).

I have a Dell XPS 14z, with a NVIDIA GeForce GT 520M 1GB graphics with Optimus. I don't not have ANY issues with the same card on the same computer under Windows 7. My kernel is: 3.2.0-23.36.

Any help with this would be great, I really would like my NVIDIA driver to work.

xorg.conf:

# nvidia-xconfig: X configuration file generated by nvidia-xconfig
# nvidia-xconfig:  version 295.49  (buildmeister@swio-display-x86-rhel47-07.nvidia.com)  Tue May  1 00:54:24 PDT 2012


Section "ServerLayout"
    Identifier     "Layout0"
    Screen      0  "Screen0" 0 0
    InputDevice    "Keyboard0" "CoreKeyboard"
    InputDevice    "Mouse0" "CorePointer"
EndSection

Section "Files"
EndSection

Section "InputDevice"

    # generated from default
    Identifier     "Mouse0"
    Driver         "mouse"
    Option         "Protocol" "auto"
    Option         "Device" "/dev/psaux"
    Option         "Emulate3Buttons" "no"
    Option         "ZAxisMapping" "4 5"
EndSection

Section "InputDevice"

    # generated from default
    Identifier     "Keyboard0"
    Driver         "kbd"
EndSection

Section "Monitor"
    Identifier     "Monitor0"
    VendorName     "Unknown"
    ModelName      "Unknown"
    HorizSync       28.0 - 33.0
    VertRefresh     43.0 - 72.0
    Option         "DPMS"
EndSection

Section "Device"
    Identifier     "Device0"
    Driver         "nvidia"
    VendorName     "NVIDIA Corporation"
EndSection

Section "Screen"
    Identifier     "Screen0"
    Device         "Device0"
    Monitor        "Monitor0"
    DefaultDepth    24
    SubSection     "Display"
        Depth       24
    EndSubSection
EndSection

The (EE) in /var/log/Xorg.0.log is:

[    10.014] (EE) Failed to load module "nvidia" (module does not exist, 0)
share|improve this question
    
Do you see any errors (EE) or Segmentation fault in /var/log/Xorg.0.log? –  jrennie May 11 '12 at 2:36
    
Yeah, I found an (EE) to do with NVIDIA: '[ 10.014] (EE) Failed to load module "nvidia" (module does not exist, 0)' –  Alistair Francis May 12 '12 at 5:23

1 Answer 1

Just to make sure, check that you have the nvidia package installed. The following command should show ii at the far left on the nvidia line:

sudo dpkg -l nvidia-current

Assuming you do have the nvidia package installed, I'd give the "nouveau" driver a try. It's open source, and seems to have fewer issues than the binary one, but it's not as fast. To try it, edit /etc/X11/xorg.conf and change the "Device" Driver line from "nvidia" to "nouveau".

Before restarting X, make sure nouveau is installed:

sudo apt-get install xserver-xorg-video-nouveau

You might need to remove the binary driver(s) in order for "nouveau" to work:

sudo apt-get remove nvidia-current nvidia-current-updates

You may need to reboot after any of the above changes to see it working as expected (unless you are very familiar with Ubuntu kernel module (un)loading).

Btw, there are known issues with nvidia-current. See Launchpad bug #980298. Also, you state that nvidia-current-updates is 295.49, but packages.ubuntu.com seems to think that it is 295.40. So, you may have better luck when Ubuntu officially rolls out 295.49. Alternatively, the Launchpad bug has a link to a deb for 295.49.

share|improve this answer
    
Thanks, I have the nouveau one running now, I have complete removed anything to do with NVIDIA. I would like to get it working, so then I can try bumblebee as at the moment, my battery life is shocking (compared to Windows) in Ubuntu –  Alistair Francis May 13 '12 at 10:08
    
Thanks for the help, I might wait a bit and try again, other wise report a bug –  Alistair Francis May 13 '12 at 10:12

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.